Kepler - Bug #5508

Link to "Additional background information on Ptolemy" brings up empty page
10/05/2011 06:51 PM - Christopher Brooks
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Bugzilla-ld: 5508

Description

Under Windows Server 2008:

If I do Help -> Kepler Documentation,

and click on

"packground information on Ptolemy"

| get a blank page that has
jar:file:!/ptolemy/configs/ptinyKepler/intro.htm in the title.

| looked in the jar file and the file is there?
View ->Source brings up a NPE?

java.lang.reflect.InvocationTargetException

at sun.reflect.NativeConstructorAccessorlmpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorlmpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorlmpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at ptolemy.actor.gui. TextEditorTableau$Factory.create Tableau(TextEditorTableau.java:221)
at ptolemy.actor.gui. TextEditorTableau$Factory.create Tableau(TextEditorTableau.java:279)
at ptolemy.actor.gui. TableauFrame$ViewMenuListener.actionPerformed(TableauFrame.java:1572)
at org.kepler.gui.MenuMapper$1.actionPerformed(MenuMapper.java:386)

at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)

at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)

at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)

at javax.swing.DefaultButtonModel.setPressed(Unknown Source)

at javax.swing.AbstractButton.doClick(Unknown Source)

at javax.swing.plaf.basic.BasicMenultemUl.doClick(Unknown Source)

at javax.swing.plaf.basic.BasicMenultemUI$Handler.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)

at javax.swing.JComponent.processMouseEvent(Unknown Source)

at java.awt.Component.processEvent(Unknown Source)

at java.awt.Container.processEvent(Unknown Source)

at java.awt.Component.dispatchEventimpl(Unknown Source)

at java.awt.Container.dispatchEventimpl(Unknown Source)

at java.awt.Component.dispatchEvent(Unknown Source)

at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)

at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)

at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)

at java.awt.Container.dispatchEventimpl(Unknown Source)

at java.awt.Window.dispatchEventimpl(Unknown Source)

at java.awt.Component.dispatchEvent(Unknown Source)

at java.awt.EventQueue.dispatchEventimpl(Unknown Source)

at java.awt.EventQueue.access$000(Unknown Source)

at java.awt.EventQueue$3.run(Unknown Source)

at java.awt.EventQueue$3.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.security.ProtectionDomain$1.dolntersectionPrivilege(Unknown Source)

at java.security.ProtectionDomain$1.dolntersectionPrivilege(Unknown Source)

at java.awt.EventQueue$4.run(Unknown Source)

at java.awt.EventQueue$4.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)
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at java.security.ProtectionDomain$1.dolntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)

Caused by: java.lang.NullPointerException

at ptolemy.actor.gui. TextEditor.getBackground(TextEditor.java:144)

at java.awt.Window.setBackground(Unknown Source)

at java.awt.Frame.setBackground(Unknown Source)

at ptolemy.gui.Top.access$1001(Top.java:141)

at ptolemy.gui.Top$SetBackgroundRunnable.run(Top.java:1889)

at ptolemy.gui.Top.deferlfNecessary(Top.java:247)

at ptolemy.gui.Top.setBackground(Top.java:501)

at ptolemy.actor.gui. TextEditor.setBackground(TextEditor.java:238)

at javax.swing.JFrame.framelnit(Unknown Source)

at javax.swing.JFrame.<init>(Unknown Source)

at ptolemy.gui.Top.<init>(Top.java:162)

at ptolemy.actor.gui.TableauFrame.<init>(TableauFrame.java:133)

at ptolemy.actor.gui.TableauFrame.<init>(TableauFrame.java:168)

at ptolemy.actor.gui. TextEditor.<init>(TextEditor.java:104)

at ptolemy.actor.gui. TextEditor.<init>(TextEditor.java:91)

at ptolemy.actor.gui.TextEditorTableau.<init>(TextEditorTableau.java:89)

at ptolemy.actor.gui.TextEditorTableau.<init>(TextEditorTableau.java:68)

... 46 more

This page works on the Mac and | don't get the NPE.

History

#1 - 11/08/2011 06:54 PM - Derik Barseghian

I haven't been able to reproduce this on XP. | don't have Windows Server 2008, so will probably need you to test again when | release rc3.

#2 - 11/13/2011 06:03 PM - Christopher Brooks

The latest Kepler 2.3.0 rc3 continues to display a blank intro window under Windows Server 2008 when run with Java 1.7:

$ /cygdrive/C/Program\ Files/Java/jdk1.7.0/bin/java -version

java version "1.7.0"

Java(TM) SE Runtime Environment (build 1.7.0-b147)

Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)

Administrator@JOULE /cygdrive/c/Program Flles/Kepler-2.3
$ /cygdrive/C/Program\ Files/Java/jdk1.7.0/bin/java -jar kepler.jar

Then do Help -> Kepler Documentation,

and click on

"background information on Ptolemy"

| get a blank page that has
jar:file:!/ptolemy/configs/ptinyKepler/intro.htm in the title.

The problem occurs when | run from the command line or via kepler.exe.
In both cases, Java 1.7 is being used.

However, the problem does not occur under Windows Server 2008 with
Java 1.6 when | invoked:

$ /cygdrive/C/Program\ Files/Java/jdk1.6.0_26/bin/java -version
java version "1.6.0_26"

Java(TM) SE Runtime Environment (build 1.6.0_26-b03)

Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)
Administrator@JOULE /cygdrive/c/Program Flles/Kepler-2.3
/cygdrive/C/Program\ Files/Java/jdk1.6.0_26/bin/java -jar kepler.jar

The problem also does not occur under Windows 2003 when Kepler is invoked
with Java 1.6
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Note that Windows Server 2008/Java 1.7 is quite close to Windows 7, so this

bug could be quite common.

| can replicate this using the Ptolemy Il nightly build under Java 1.7, so
I'll take a look.

#3 - 11/14/2011 02:54 PM - Christopher Brooks

This is a Java 1.7 problem, I'm able to replicate the problem under Java 1.7

under Mac OS X.

| checked in a fix:
bash-3.2$ svn diff -r 62410 ~/ptll/ptolemy/actor/gui/HTMLViewer.java
Index: /Users/cxh/ptll/ptolemy/actor/gui/HTMLViewer.java

--- /Users/cxh/ptll/ptolemy/actor/gui/HTMLViewer.java (revision 62410)
+++ /Users/cxh/ptll/ptolemy/actor/gui/HTMLViewer.java (working copy)
@ -53,6 +53,7 @

import ptolemy.gui.Top;

import ptolemy.kernel.util.StringAttribute;
+import ptolemy.util.ClassUtilities;

import ptolemy.util.MessageHandler;

L1777 7007777777777777777777777777777777777777777177777717777777777

@ -356,6 +357,16 @
* (@see f#getPage ()
=/

public void setPage (URL page) throws IOException {
URL jarURL = ClassUtilities.jarURLEntryResource (page.toString());

if (jarURL != null) {
// Under Java 1.7, JEditorPane.setPage ()

// not ptsupport.jar. So, we look up the
// See http://bugzilla.ecoinformatics.org

handles jar urls

// differently. 1In Java 1.6, setPage() would correctly open
// Jar:file:/Users/cxh/ptII/ptolemy/ptsupport.jar!/doc/mainVergilPtiny.htm
// even though doc/MainVergilPtiny.htm is in doc/docConfig. jar,

jar URL.
show_bug.cgi?id=5508

page = JjarURL;

+ 4+ + + + + + A+ + +

}
pane.setPage (page) ;
}

This fix should be folded in to Kepler-2.3, which means creating another
release candidate.

#4 - 11/14/2011 11:10 PM - Derik Barseghian

It's probably worth it, but note this means a large jump in the utilized revision of ptolemy (61797 to 62410) and represents a bit of work:

bug#5540 should be fixed.

build-area-2.3 needs to be deleted and recreated at release (due to movement of jars)

Export As=>XML, PNG, etc need to be tested, I've seen work in this area in ptolemy
I'll have to remember the black magic used to create a ptolemy 2.3 that doesn't keep a copy of the ptolemy code on our repository.

(And | think I'm forgetting a few other kepler changes that should/will have to be included)

(In reply to comment #3)

This is a Java 1.7 problem, I'm able to replicate the problem under Java 1.7

under Mac OS X.

| checked in a fix:

bash-3.2$ svn diff -r 62410 ~/ptll/ptolemy/actor/gui/HTMLViewer.java

Index: /Users/cxh/ptll/ptolemy/actor/gui/HTMLViewer.java

--- /Users/cxh/ptll/ptolemy/actor/gui/HTMLViewer.java (revision 62410)
+++ /Users/cxh/ptll/ptolemy/actor/gui/HTMLViewer.java (working copy)

@ -53,6 +53,7 @

import ptolemy.gui.Top;

import ptolemy.kernel.util.StringAttribute;
+import ptolemy.util.ClassUtilities;
import ptolemy.util. MessageHandler;

it
@ -356,6 +357,16 @
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https://projects.ecoinformatics.org/ecoinfo/issues/3

* @see #getPage()

*/

public void setPage(URL page) throws IOException {
URL jarURL = ClassUtilities.jarURLEntryResource(page.toString());
if (jarURL != null) {

/' Under Java 1.7, JEditorPane.setPage() handles jar urls

// differently. In Java 1.6, setPage() would correctly open

1
jar:file:/Users/cxh/ptll/ptolemy/ptsupport.jarl/doc/mainVergilPtiny.htm
/I even though doc/MainVergilPtiny.htm is in doc/docConfig.jar,
/I not ptsupport.jar. So, we look up the jar URL.
/I See http://bugzilla.ecoinformatics.org/show_bug.cgi?id=5508
page = jarURL;

+ + o+ + o+

ane.setPage(page);

~— T + + + + +

This fix should be folded in to Kepler-2.3, which means creating another
release candidate.

#5 - 11/14/2011 11:14 PM - Christopher Brooks

| would fold the change to HTMLViewer in to a branch just 2.3. | agree that there are many changes and we may not want all of them.

The missing Kieler Layout functionality should possibly be fixed.
It is very useful.

The export PNG facility could be skipped.

Just my $0.02.

#6 - 11/15/2011 12:14 AM - Derik Barseghian

Do you mean you'd create a branch (61797 + 62410) in the ptolemy repo with this change for me to refer to?

Otherwise the solution is for me to copy the ptolemy 61797 source to the kepler repository, and patch, which is how 2.2 worked, and something |
thought we discussed and decided is not good -- the keeping (and patching) of ptll code on the kepler repository.(?)

Kieler layout works in kepler 2.3, it just doesn't work on trunk, either because of a change in kepler trunk or a change in ptolemy trunk, so if we go with
either of the above options there's nothing to fix. The Export options should likewise continue to work and shouldn't require extra testing.

#7 - 11/15/2011 10:18 AM - Christopher Brooks

Ok, | created a branch with:

svn copy -r 61797 svn+ssh://source.eecs.berkeley.edu/chess/ptll/trunk svn+ssh://source.eecs.berkeley.edu/chess/ptll/branches/kepler-2-3 -m
"Creating Kepler-2.3 branch"

Is r61797 the right revision?

To check it out, use
svn co svn+ssh:/source.eecs.berkeley.edu/chess/ptll/branches/kepler-2-3 ptll-kepler2.3

or

svn co https://source.eecs.berkeley.edu/svn/chess/ptll/branches/kepler-2-3 ptll-kepler2.3

| checked in the change to HTMLViewer.java

For my own notes, | verified the fix with:

1, Checking out the branch

2. Copying ptll/build.default.xml to build.xml and excluding
ptolemy/actor/lib/logic/fuzzy

and

ptolemy/domains/jogl

3. Building with

ant

4. Copied ptll/jars.xml

5. Built the jar files with

ant -f jars.xml jars

6. Created a script called "doit" that uses just jar files:
java -classpath
"${PTIl}/ptolemy/ptsupport.jar:${PTII}/ptolemy/vergil/vergil.jar:${PTII}/lib/diva.jar:${PTll}/doc/docConfig.jar:${PTIl}/ptolemy/domains/domains.jar"
ptolemy.vergil.VergilApplication -ptiny

7. cd'd to a subdirectory so that $PTIl was not the cwd (thus avoiding
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accidentally finding source files in the path.

8. Ran

sh ../doit

9. Clicked on Overview. The title of the window ended in
ptsupport.jar!/doc/mainVergil.htm

10. File -> New ->Graph Editor -> View -> JVM Properties indicates that
java.version = 1.6.0_29

11. Exit vergil.

12. Under Mac OS X, | had installed a preview version of Java 1.7, so
under Utilities, | selected the Java Preferences program and dragged
the 64 bit version of Java 1.7 to the top and exited Java Preferences.
13. Reran

sh ../doit

14. | get this stack trace in stdout, which | ignore:

Exception in thread "AWT-EventQueue-0" java.lang.lllegalArgumentException: Width (-1) and height (-1) cannot be <= 0
at java.awt.image.DirectColorModel.createCompatibleWritableRaster(DirectColorModel.java:1016)

at java.awt.image.Bufferedlmage.<init>(Bufferedlmage.java:357)
at sun.lwawt.macosx.Clmage$Creator.createFromimage(Clmage.java:101)

at sun.lwawt.macosx.CPlatformWindow.getlmageForTarget(CPlatformWindow.java:693)
at sun.lwawt.macosx.CPlatformWindow.updatelconimages(CPlatformWindow.java:519)
at sun.lwawt.macosx.CPlatformWindow.setVisible(CPlatformWindow.java:484)

at sun.lwawt.LWWindowPeer$1.run(LWWindowPeer.java:260)

at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
at java.awt.EventQueue.dispatchEventimpl(EventQueue.java:705)

at java.awt.EventQueue.access$000(EventQueue.java:101)

at java.awt.EventQueue$3.run(EventQueue.java:666)

at java.awt.EventQueue$3.run(EventQueue.java:664)

at java.security.AccessController.doPrivileged(Native Method)

at java.security.ProtectionDomain$1.dolntersectionPrivilege(ProtectionDomain.java:76)

at java.awt.EventQueue.dispatchEvent(EventQueue.java:675)

at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:240)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:157)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:142)

at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:134)

at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

15. The various links in the splash screen work
16. File -> New ->Graph Editor -> View -> JVM Properties has:
java.version = 1.7.0-ea

#8 - 11/15/2011 08:10 PM - Derik Barseghian

Yes r61797 is right.
Thanks for doing this.
I'll try to switch kepler-2.3 to use this branch, probably early next week.

(In reply to comment #7)

Ok, | created a branch with:
svn copy -r 61797 svn+ssh://source.eecs.berkeley.edu/chess/ptll/trunk

svn+ssh://source.eecs.berkeley.edu/chess/ptll/branches/kepler-2-3 -m "Creating

Kepler-2.3 branch"
Is r61797 the right revision?

To check it out, use

svn co svn+ssh:/source.eecs.berkeley.edu/chess/ptll/branches/kepler-2-3

ptll-kepler2.3

or

svn co https://source.eecs.berkeley.edu/svn/chess/ptll/branches/kepler-2-3

ptll-kepler2.3
| checked in the change to HTMLViewer.java

For my own notes, | verified the fix with:

1, Checking out the branch

2. Copying ptll/build.default.xml to build.xml and excluding
ptolemy/actor/lib/logic/fuzzy

and

ptolemy/domains/jogl

3. Building with

ant
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4. Copied ptll/jars.xml

5. Built the jar files with

ant -f jars.xml jars

6. Created a script called "doit" that uses just jar files:

java -classpath
"${PTII}/ptolemy/ptsupport.jar:${PTII}/ptolemy/vergil/vergil.jar:${PTII}/lib/diva.jar:${PTll}/doc/docConfig.jar:${PTIl}/ptolemy/domains/domains.jar"
ptolemy.vergil.VergilApplication -ptiny

7. cd'd to a subdirectory so that $PTII was not the cwd (thus avoiding

accidentally finding source files in the path.

8. Ran

sh ../doit

9. Clicked on Overview. The title of the window ended in
ptsupport.jar!/doc/mainVergil.htm

10. File -> New ->Graph Editor -> View -> JVM Properties indicates that

java.version = 1.6.0_29

11. Exit vergil.

12. Under Mac OS X, | had installed a preview version of Java 1.7, so

under Utilities, | selected the Java Preferences program and dragged

the 64 bit version of Java 1.7 to the top and exited Java Preferences.

13. Reran

sh ../doit

14. | get this stack trace in stdout, which | ignore:

Exception in thread "AWT-EventQueue-0" java.lang.lllegalArgumentException:

Width (-1) and height (-1) cannot be <=0

at
java.awt.image.DirectColorModel.createCompatibleWritableRaster(DirectColorModel.java:1016)
at java.awt.image.Bufferedlmage.<init>(Bufferedlmage.java:357)

at sun.lwawt.macosx.Clmage$Creator.createFromimage(Clmage.java:101)

at
sun.lwawt.macosx.CPlatformWindow.getimageForTarget(CPlatformWindow.java:693)
at
sun.lwawt.macosx.CPlatformWindow.updatelconimages(CPlatformWindow.java:519)
at

sun.lwawt.macosx.CPlatformWindow.setVisible(CPlatformWindow.java:484)

at sun.lwawt.LWWindowPeer$1.run(LWWindowPeer.java:260)

at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)

at java.awt.EventQueue.dispatchEventlmpl(EventQueue.java:705)

at java.awt.EventQueue.access$000(EventQueue.java:101)

at java.awt.EventQueue$3.run(EventQueue.java:666)

at java.awt.EventQueue$3.run(EventQueue.java:664)

at java.security.AccessController.doPrivileged(Native Method)

at
java.security.ProtectionDomain$1.dolntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:675)

at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:240)
at
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:157)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:146)
at

java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:142)

at

java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:134)

at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

15. The various links in the splash screen work
16. File -> New ->Graph Editor -> View -> JVM Properties has:
java.version = 1.7.0-ea

#9 - 11/21/2011 02:58 PM - Derik Barseghian

I've switched kepler-2.3 to use this new branch of ptolemy.

On Windows XP | installed java 1.7 (runtime 1.7.0.01_b08) and recompiled and started kepler-2.3, and tried the 'background information on Ptolemy’,
and it works.

I think this is safe to close, but will leave open until we test on the next rc.

#10 - 11/21/2011 07:28 PM - Derik Barseghian

Verified fixed in rc4 on XP w/ java7
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#11 - 11/22/2011 11:17 AM - Christopher Brooks

Verified fixed in rc4 on Windows Server 2008 w/ java7

#12 - 03/27/2013 02:30 PM - Redmine Admin
Original Bugzilla ID was 5508
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