Project

General

Profile

Revision 10012

Added by Jing Tao almost 5 years ago

Change the solr core to 3.6.2

View differences:

metacat-common/pom.xml
41 41
		<dependency>
42 42
			<groupId>org.apache.solr</groupId>
43 43
			<artifactId>solr-core</artifactId>
44
			<version>3.4.0</version>
44
			<version>3.6.2</version>
45 45
			<exclusions>
46 46
                <exclusion>
47 47
                  <groupId>org.slf4j</groupId>
......
57 57
		<dependency>
58 58
			<groupId>org.apache.solr</groupId>
59 59
			<artifactId>solr-test-framework</artifactId>
60
			<version>3.4.0</version>
60
			<version>3.6.2</version>
61 61
		</dependency>
62 62
		<dependency>
63 63
			<groupId>org.dataone</groupId>
metacat-common/src/main/java/edu/ucsb/nceas/metacat/common/query/SolrQueryResponseWriterFactory.java
26 26
import org.apache.solr.response.PythonResponseWriter;
27 27
import org.apache.solr.response.QueryResponseWriter;
28 28
import org.apache.solr.response.RubyResponseWriter;
29
import org.apache.solr.response.VelocityResponseWriter;
29
//import org.apache.solr.response.VelocityResponseWriter;
30 30
import org.apache.solr.response.XMLResponseWriter;
31 31

  
32 32
/**
......
69 69
            writer = new PHPResponseWriter();
70 70
        } else if(wt.equals(PHPS)) {
71 71
            writer = new PHPSerializedResponseWriter();
72
        } else if(wt.equals(VELOCITY)) {
73
            writer = new VelocityResponseWriter();
72
        /*} else if(wt.equals(VELOCITY)) {
73
            writer = new VelocityResponseWriter();*/
74 74
        } else if(wt.equals(CSV)) {
75 75
            writer = new CSVResponseWriter();
76 76
        } else {
metacat-common/src/test/java/edu/ucsb/nceas/metacat/common/query/SolrQueryServiceControllerTest.java
32 32
        String version = SolrQueryServiceController.getInstance().getSolrSpecVersion();
33 33
        //System.out.println("version is ======================== "+version);
34 34
        assertTrue(version != null);
35
        assertTrue("The version should be 3.4.0.2011.09.09.09.06.42 rather than "+version, version.equals("3.4.0.2011.09.09.09.06.42"));
35
        assertTrue("The version should be 3.6.2.2012.12.18.19.52.59 rather than "+version, version.equals("3.6.2.2012.12.18.19.52.59"));
36 36
    }
37 37
    
38 38
    

Also available in: Unified diff