Project

General

Profile

Statistics
| Revision:

metacat / src / edu / ucsb / nceas @ 6490

Name Size Revision Age Author Comment
  dbadapter 5030 about 12 years daigle Change location of PropertyService to propertie...
  metacat 6490 about 10 years ben leinfelder comment out resynch() method until errors are r...
  protocols 3077 almost 15 years Matt Jones Removed the @release@ ant token from all files ...
  shared 5015 about 12 years daigle Create database and shared directories for data...

Latest revisions

# Date Author Comment
6490 09/21/2011 05:45 PM ben leinfelder

comment out resynch() method until errors are resolved

6489 09/21/2011 05:25 PM ben leinfelder

use default hazelcast config when not configured to use an external one

6484 09/21/2011 04:58 PM Chris Jones

Don't use the hzNodes map yet (as a hazelcast client). Use D1Client instead to get the node list in isNodeAuthorized().

6483 09/21/2011 04:51 PM Chris Jones

For now, remove the hzClient code connecting to the DataONE process cluster to get the hzNodes map. This will be moved into the storage cluster, but use D1Client to get the node list for now.

6481 09/21/2011 10:54 AM rnahf

going back to using IDentifier as the key for the ObjectPAthMap.

6476 09/20/2011 10:20 PM Matt Jones

Fix getCapabilities to properly throw ServiceFailure when properties can not be read, rather than failing with a log message. Fix properties in the Node object to reflect their correct values. Set the sync schedule properly to default to 5 minute intervals. Improve documentation.

6475 09/20/2011 08:52 PM Matt Jones

Reformatted to correct indentation to make class readable.

6474 09/20/2011 02:32 PM ben leinfelder

newer d1 jars -- contains CN.isNodeAuthorized() method

6472 09/20/2011 02:11 PM ben leinfelder

collect "message" param from multipart request for MN.synchronizationFailed method

6471 09/20/2011 02:08 PM Matt Jones

Reverting previous @Overrides chanrge from r6470, as that is the desired
behavior under Java 1.6 -- previous versions of Java (e.g., 1.5) will not
comile with this usage of the @Overrides annotation, but the currently
supported version will. So reverting to the 1.6 convention.

View revisions

Also available in: Atom