Project

General

Profile

Bug #1190

Change User Profile seems to be broken

Added by Michael Lee almost 19 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
misc
Target version:
Start date:
10/24/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1190

Description

I tried to change my user profile to update my address, but it said that I
should choose a unique email. Seemingly, it searches the database to see if the
email is already there, which it is, because it's my email and I didn't try to
change it. When I did change my email to something else, it did work. It needs
to only check that no one else (other than me) has the email I change the email
to (if I change it at all).

Also, need to log-out a user when they change their email. Or at least tell them
to logout and log back in. The cookie doesn't get updated, so when a user tries
to change the profile again, they get a white screen. At least I did.


Related issues

Is duplicate of VegBank - Bug #1119: Changing email address doesn't affect cookie email addressResolved07/22/2003

History

#1 Updated by Michael Lee almost 19 years ago

Also need to deal with cookie and main menu greeting if email address changed.

From bug 1119 (dupl of this):
When the user changes email address in the change profile page, they are sent
back to the main menu and the old email address is still displayed. It would
be nice to update this. (or better yet, use their name rather than their
email).

2 ways we could make this a bit slicker, quite easily. 1) auto-login the user
after an email change with the new email address and 2) warn that this change
will take place after they log-out, so that they know the change has indeed
been made. I think the problem is that the email address is stored in the
cookie, hence when you go to the main menu, the old email address appears, b/c
that's what's read from the cookie.

Bob's original comments about this:

One minor little bug I noticed while trying to break the system. If you
change your email address, it works but the system seems to think you are
still logged in as your old email address. The header will be addressed
to the old registration, and if you try to become certified and enter your
email as the new one you will be rejected and will need to enter the old
email. This could be fixed by requiring a logout and then a fresh login,
or it could be more elegant.

#2 Updated by Michael Lee almost 19 years ago

  • Bug 1119 has been marked as a duplicate of this bug. ***

#3 Updated by P. Anderson over 18 years ago

The whole user system (aka usr system to reflect name of DB table) has been reworked
and actually functions properly. There have also been some cosmetic changes.

Right on schedule.

#4 Updated by Michael Lee over 17 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

#5 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 1190

Also available in: Atom PDF