Project

General

Profile

Bug #3670

Kepler data download throws exception

Added by Michael Daigle almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Normal
Category:
metacat
Target version:
Start date:
11/13/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3670

Description

When trying to view data for kepler in 1.8.1, the system throws the following exception:

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: malformed lsid
com.ibm.lsid.server.servlet.BaseServlet.doGet(BaseServlet.java:127)
javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

root cause

com.ibm.lsid.MalformedLSIDException: 200 : LSID must be of the form: urn:lsid:<AuthorityID>:<NamespaceID>:<ObjectID>:[RevisionID], got: urn:lsid: not found: [] Root Cause: java.util.NoSuchElementException null
com.ibm.lsid.LSID.<init>(LSID.java:60)
com.ibm.lsid.server.servlet.BaseServlet.doGet(BaseServlet.java:125)
javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

note The full stack trace of the root cause is available in the Apache Tomcat/5.5.23 logs.

History

#1 Updated by Michael Daigle almost 11 years ago

The xml_queryresult table needs to be cleared in the kepler database. A bad query has been cached and keeps returning bad values.

#2 Updated by Michael Daigle almost 11 years ago

Jing is taking care of this

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3670

Also available in: Atom PDF