Project

General

Profile

Bug #3866

Undo does not work on question type change action

Added by Jay Lee almost 10 years ago. Updated about 9 years ago.

Status:
In Progress
Priority:
Normal
Category:
parser
Target version:
Start date:
03/08/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3866

Description

when undo button is clicked, it's not actually doing the right job. it does not go back to previous stage but some point, and it messed up somehow.

History

#1 Updated by ben leinfelder almost 10 years ago

I don't believe the undo button can undo everything - mostly just typing actions (and perhaps those are even character by character?)
What were you trying to "undo"?

#2 Updated by ben leinfelder almost 10 years ago

from jay:
Yes. I figured that out. Most of time it works fine with typing steps. What
I was having problem was that if I undo when I change to "multiple choice"
to "Short answer" or vice versa, then clicking undo button somehow remove
question text.

#3 Updated by Ryan McFall over 9 years ago

Resubmit after fire

#4 Updated by Ryan McFall about 9 years ago

Sandeep, this would be good to look at.

#5 Updated by Sandeep Namilikonda about 9 years ago

In reply to comment 2:

Undo/Redo buttons or equivalent Edit menu items are not activated when a
question's type is changed. But, when the question type is manually
changed from one type (say multiple choice) to another (say True/False)
and back, I did not find any text missing, either from the prompt or
from the choices.

I do not know if we decided to have "undo" functionality for even
question type changes. My opinion is that such a functionality can be
added at post-prototype stage, if we deem it necessary.

Please comment.

#6 Updated by Redmine Admin over 5 years ago

Original Bugzilla ID was 3866

Also available in: Atom PDF