Project

General

Profile

Bug #3882

KNB Web links don't work correctly

Added by Michael Daigle over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
metacat
Target version:
Start date:
03/11/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3882

Description

There are several issues with links and hardcoded paths in knbweb. These have been reproduced in a dev environment.

Per Matt:

4) Go to main KNB site (http://knb.ecoinformatics.org), click on
register online link
4a) Login form shows up but is missing styles (looks like same css
problem as (1) above)
4b) Filling in my username and password results in a 404 error:
"The requested URL /register-dataset.cgi was not found on this server."
This is a bit confusing as it should get the same error as the
NCEAS skin in (2) above, so is it a different install of
register-dataset.cgi? Or is this a misconfigured login form that's
pointing to a non-existent script location? Probably the latter.

History

#1 Updated by Michael Daigle over 10 years ago

This was found after the 1.9.0 metacat release to KNB.

#2 Updated by Michael Daigle over 10 years ago

Two issues. KNB web was still looking for cgi in the /cgi-knb directory. Changed it to look in /knb/cgi-bin.

Knbweb was not easily installed on systems other than production because of hard-coded server values. Moved the server and context configuration into PORTAL_SETTINGS.jsp.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3882

Also available in: Atom PDF