Project

General

Profile

Bug #4309

Some of Data packages could not be uploaded to web

Added by Jay Lee almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
dataserver
Target version:
Start date:
08/13/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4309

Description

there are two cases of error when Data package was uploaded into web server.

First, Entire parsed items are not uploaded with error message "Document not found for accession number". 2003 Fall Exam 2 Form A, 2004 Fall Exam 2, 2004 Fall Final, and 2006 Fall Exam 2 fall into this case.

Second, some of parsed items are not be able to be uploaded into Web server.
It gives error message " problem saving assessment item datapackage"

Eor example, when 2006 Fall Exam 3 was uploaded into web, the item id 1889.1 gave error message and could not be uploaded into web but rest of items were successfully uploaded into web. 2002 Fall Exam1, 2004 Fall Exam3, 2005 Fall Final, 2005 Midterm ver A, 2006 Fall Exam3, and 2006 Fall Final belong to this error case.
more detail description for error items id for this error. see the FIRST_data_Log.xls at FIRST angel website.


Related issues

Blocks FIRST - Bug #4315: Images repeating when editing assessment itemsResolved08/14/2009

History

#1 Updated by ben leinfelder almost 10 years ago

Can you describe the exact steps you took when saving to the network?
Was the assessment fully saved locally before you attempted to save to the network?

You might also try using the File->Synchronize... option to see if you can push your local copy to the network.

If that doesn't work, then I'd like you to point at 'http://fred.msi.ucsb.edu:8080/knb/metacat' again and try saving there so that I have more control over what is happening.

#2 Updated by ben leinfelder almost 10 years ago

from Jay
--------
Hi Ben,

Before I tried to save data package into web, the data package was fully
parsed and saved with no problem into local drive. And then I tried to save
it to web server. I chose the menu -> save -> mark "Save to Network" .
If you go to First angel website, there is log file under Morpho Database
Log folder that I created.
It has information that what data package have trouble to upload. I also
upload data package backup file under Morpho Backup Data. There are two
backup file. The one with August 13 is the latest one.

As you asked me, I changed the metacat URL to Fred and tried to upload some
of data packages. Same error message pop up. Even the data package that did
not have trouble to upload EGR server, now I could not upload them into Fred
with same error message " Document not found for accession number".

Let me know what else I should try on.

Jay

#3 Updated by ben leinfelder almost 10 years ago

I downloaded Jay's latest Morpho backup and used it form my Morpho - saved to fred.msi.ucsb.edu successfully (jlee.220.3) "2003 Fall Exam Form A". Downloaded same exam too.

#4 Updated by ben leinfelder almost 10 years ago

When you set the URL to a different Metacat server - please hit the "Clear Temporary Storage"
That may have something to do with the trouble you are having uploading to different servers and even the EGR server (but I'm not sure).

#5 Updated by ben leinfelder almost 10 years ago

I couldn't upload all of jlee.220.3 to the EGR server because:
a) I don't have full access to the data file it references (jlee.260.6)
b) i don't have write permission for the actual assessment (jlee.220.3)

Jay should be able to save this exam (I did it on fred where there wasn't already a record of his save)
You can try:
-making a slight modification (change the title)
-saving locally
-changing the title back
-saving locally
-saving to the server

This might get the IDs back to a place where there are no conflicts and a save can occur.

#6 Updated by Jay Lee almost 10 years ago

ok. as i directed by Ben, I clear up Temporary storage in Norpho and tried to upload some data package to Fred server that had trouble to upload to EGR server. it showed the different behavior. For example, 2004 Fall Exam 2 data package did have error " Document not found accession number" on EGR server. but it was partially able to be uploaded into Fred Server. there was only one item having trouble to upload it.

#7 Updated by ben leinfelder almost 10 years ago

what was the item it had an error with? what was the error?

#8 Updated by Jay Lee almost 10 years ago

I didn't make record of it. so i tried other Exam, 2006 Fall Exam 2.
the item having trouble was jlee1800.2. it said, Problem Saving Accessement item data package".

The rest of items were successfully uploaded to Fred server.

#9 Updated by ben leinfelder almost 10 years ago

Please make sure you grant public read to both the assessment and the data
I see jlee.1800.1 on the server (internally) but I do not appear to have read access via the web.
You an also try the "File->Synchronize..." option and see if that resolves the error

#10 Updated by Jay Lee almost 10 years ago

Hum. it's kind of weired. after i granted you access, I tried to use the menu "Synchronize" but that menu is unactivated.

I notice before that once you saved your data package int server, that menu is unactiavted.

So i i tried to save it again and it gave me other items this time, id id=jlee1755.5.

#11 Updated by ben leinfelder almost 10 years ago

there is no jlee.1755.5 on the server - only jlee.1755.2:
http://fred.msi.ucsb.edu:8080/knb/metacat/jlee.1800/first
I'm not sure what you are doing at this point.

#14 Updated by ben leinfelder almost 10 years ago

There is, however, a problem with the IDs - at least for jlee.1800.2 (there is only jlee.1800.1 on fred) this will cause the data download to fail even though you can see most of the assessment (2006 Fall Exam 2 (jlee.1753.3) )has been uploaded.
I'm not sure how best to recover from that.

#15 Updated by ben leinfelder almost 10 years ago

I did notice that jlee.1800.1 has one prompt with <html> tags in it. This is supposed to be supported (they are wrapped in CDATA) but I did see a Metacat error about something it could not perform deep inside it's database representation of the XML document.

Jay - can you find the 1800.2 file in your .first...../jlee/ directory and send it to me or attach it to this bug?

#16 Updated by ben leinfelder almost 10 years ago

i loaded the updated jlee.1800.2 file onto fred (manually). and now I can download the assessment [data] from fred for:
2006 Fall Exam 2 (jlee.1753.3)
http://fred.msi.ucsb.edu:8080/knb/metacat/jlee.1753/first
(54 questions i hope!?)

#17 Updated by Jay Lee almost 10 years ago

Yes. there are 54 questions for 2006 Fall Exam2. so does that mean that we have to upload manually if there is any error with items?

#18 Updated by ben leinfelder almost 10 years ago

No, we should not have to manually upload files. I want to figure out what happened and how to fix it.
We have a few more test cases that are partially uploaded to the EGR server, correct?:
2002 Fall Exam1
2004 Fall Exam3
2005 Fall Final
2005 Midterm ver A
2006 Fall Exam3
2006 Fall Final

I can use your saved Morpho directory from Aug 13th to test some things out.

#19 Updated by ben leinfelder almost 10 years ago

For '2005 Fall Final' (jlee.1687.2) there are two questions that were serialized to invalid QTI documents:
-Question 76
-Question 77
They both contain 2 images (exact duplicates that even share the same id/filename). There should only be a single image here and in the QTI XML.

This is the offending entry:
<material><matimage imagtype="image/1" uri="ecogrid://knb/jlee.2484.1"> </matimage>
</material>
It appears just before the start of the <render_fib> tag

#20 Updated by ben leinfelder almost 10 years ago

I've corrected question 76 and 77 to only include the single image and resaved '2005 Fall Final' (jlee.1687) to fred successfully. I guess i'll try it on the egr server now - but i suspect i will have permission errors when colliding with Jay's initial upload attempts.

#21 Updated by ben leinfelder almost 10 years ago

It seems that our handling of images in the Assessment Parser is creating some invalid QTI documents - these then cause problems with the entire exam: IDs get out of synch and "everything" seems to crumble apart. Looks like there's some parsing code that creates additional image entries everytime there is a save. For a question that has revision of 3 i see this:
<matimage imagtype="image/1" uri="ecogrid://knb/jlee.1423.1"> </matimage>
<matimage imagtype="image/1" uri="ecogrid://knb/jlee.1423.1"> </matimage>
<matimage imagtype="image/1" uri="ecogrid://knb/jlee.1423.1"> </matimage>
<matimage imagtype="image/1" uri="ecogrid://knb/jlee.1423.1"> </matimage>

there should only be one.
also - that block of 4 is repeated in another location in the same question.
not good!

#22 Updated by ben leinfelder almost 10 years ago

since 4315 is resolved can we retest this and close this bug?

#23 Updated by Sandeep Namilikonda almost 10 years ago

This issue has been tested and confirmed resolved.

#24 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4309

Also available in: Atom PDF