Project

General

Profile

Feature #5914

Reconcile SOLR server/client versions

Added by ben leinfelder over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
04/12/2013
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

DataONE schema uses SOLR v3.x and Metacat-indexer wants to use SOLR v4.x (for the client capabilities). There are schema incompatibilities between the two.

We could potentially run the server on 3.x and use the 4.x client to communicate with it. But this needs to be tested.

Other options:
- fork and modify the existing DataONE schema to comply with 4.x features.
- encourage (force) DataONE to upgrade their SOLR deployment to use 4.x

History

#1 Updated by ben leinfelder over 7 years ago

  • Status changed from New to Closed

Both client and server are using v3.x now. Eventually DataONE plans to update the SOLR version, so we can consider this again at that time.

Also available in: Atom PDF