Project

General

Profile

Bug #6427

Log-in form on SanPark skin doesn't work

Added by Jing Tao almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
02/26/2014
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

If you click the login button on the Sanpark skin even though input a valid user/password, the login doesn't go through. The browser's url text box will show a metacat login servlet url even with the password!

History

#1 Updated by Jing Tao almost 6 years ago

But the SAEON skin works.

#2 Updated by Jing Tao almost 6 years ago

  • Status changed from New to Resolved

I dug around and found the log-in worked on Firefox but didn't work on Chrome. The issue is the Ajax.Updater didn't send the request to Metacat at all.

I discussed with Ben and he suggested to add "return false" in the attribute "onsubmit" in the loginForm in the sanparksLogin.jsp. Then it works. I also add a new attribute "method="post"" in that form as well. This fixed the issue to put the parameters to the url. Those changed was applied to the logoutForm as well.

Then I found another issue that the re-login didn't work after the user logged out. It turned out that the re-login form is generated from the sanparksLogin.xsl. We should add above things to the sanparksLogin.xsl as well.

Also available in: Atom PDF