Project

General

Profile

Actions

Bug #6796

closed

Cannot register DOI for private object

Added by ben leinfelder over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Category:
metacat
Target version:
Start date:
07/15/2015
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

Looking through the KNB logs, I can see the EZID error when we attempted to register the DOI with metadata.

Caused by: edu.ucsb.nceas.ezid.EZIDException: bad request - invalid identifier status change

The order of events is:
1. mint DOI with EZID using minimal metadata (MN.generateIdentifier)
status=RESERVED
2. register DOI with EZID using metadata harvested from the actual object we receive (MN.create/update)
if the object is publicly readable
status=PUBLIC
else
status=UNAVAILABLE

Going from RESERVED—>UNAVAILABLE is the cause of our error with EZID. See their documentation about this here:
http://ezid.cdlib.org/doc/apidoc.html#identifier-status

Actions #1

Updated by ben leinfelder over 7 years ago

  • Status changed from New to In Progress

Added re-registration code to MN v2.updateSystemMetadata() and v1/v2.systemMetadataChanged() methods.

Actions #2

Updated by ben leinfelder about 7 years ago

  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF