Project

General

Profile

Bug #7100

Metacat Replication doesn't happen if an object is created by MN.create or CN.create

Added by Jing Tao about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
09/12/2016
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

I set up the replication between my local host and mn-demo.

In a test case, if an object is created by Metacat API, the replication will happen. However if the object is created by MN.create or CN.create, the force replication will not happen.

History

#1 Updated by Jing Tao about 3 years ago

  • Status changed from New to Resolved

The problem is:
We use the method MNodeService.getInstance(request).create(session, guid, object, sysmeta) to create object. The java call happens on the junit test class. The Force Replication happends 30 seconds after the inserting. However, the junit test already finishes and exists. So the replication can't happen. If I let the junit class's life long enough, the replication will happen!

Also available in: Atom PDF