Project

General

Profile

Bug #1013

Need to allow metacat admin to set default mime type

Added by Chris Jones over 16 years ago. Updated over 16 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
metacat
Target version:
Start date:
03/18/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1013

Description

the metacat servlet does it's best to determine the mime type of the data entity
being served. However, entities that are stored on the local filesystem with a
name in the form of prefix.1.1 don't give the servlet any clues as to the mime
type based on the file ending. As a last resort, metacat sets the default mime
type to application/octet-stream, which results in a 'download' dialog over the
web, rather than attempting to render the data file (even text/plain).

This may be desired, but some metacat admins may want text files to render
preferentially, or other file types. It seems that there needs to be a mapping
between eml dataFormat fields that hold the equivalent of a mime type (or it's
surrogate), and the true mime type name used to set the HTTP CONTENT_TYPE
header. The mapping shouldn't be schema dependent, rather, when a schema is
registered in metacat, the mapping should be registered as well.


Related issues

Has duplicate Metacat - Bug #1012: Need to allow metacat admin to set default mime typeResolved03/18/2003

History

#1 Updated by Jing Tao over 16 years ago

It is duplicate to bug 1012

  • This bug has been marked as a duplicate of 1012 ***

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 1013

Also available in: Atom PDF