Project

General

Profile

Actions

Bug #1189

closed

add full support for EML2 comple textFormat in EML ingestor

Added by Chad Berkley over 19 years ago. Updated almost 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
actors
Target version:
Start date:
10/21/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1189

Description

need to be able to read data files that are described by the complex textFormat
fields in EML2. right now the ingestor only uses the simpleDelimited fields for
parsing. See dataTable/physical/dataFormat/textFormat/complex.


Related issues

Is duplicate of Kepler - Bug #1343: need full eml2 supportResolvedChad Berkley02/10/2004

Actions
Actions #1

Updated by Chad Berkley over 18 years ago

I think matt has made some of these changes and jing is now in charge of the
eml/ecogrid integration in kepler

Actions #2

Updated by Chad Berkley over 18 years ago

  • Bug 1343 has been marked as a duplicate of this bug. ***
Actions #3

Updated by Jing Tao about 18 years ago

We need the feature that to support eml201 too.

Actions #4

Updated by Jing Tao almost 18 years ago

Create two classes - TextWidthFixedDataFormat and TextDelimitedDataFormat to
store the data format information. And in EML2Parser, to add code to get complex
format information and store them into above objects. And create
TextComplexFormatDataReader to read the complex data file to rowVectors. In
DBTableGenerator class, we add a new constructor to handle data file inputstream
rather than data vector array. Also in EMl2DataSource actor, to add code to
handle complex format data file.

Now kepler can handle complex data format and output it as all fields or part
fields(by sql query command).

Complex data format can be handled in both eml200 and eml201.

Actions #5

Updated by Redmine Admin almost 10 years ago

Original Bugzilla ID was 1189

Actions

Also available in: Atom PDF