Project

General

Profile

Bug #1237

After edit in morpho, package title and info disappears in package list

Added by David Kaplan about 17 years ago. Updated about 17 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - dsp
Target version:
Start date:
12/10/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1237

Description

I am using metacat-1.3.1 and morpho-1.4.0 and have found that editing the
overall description of a dataset (i.e. the part with the title, description,
originator, etc.) causes metacat and morpho to not display the title and other
info in the package display even though that information is still in the
document. The only solution I have found is to edit the information and add
something that was not in the document previously. For example, editing the
document and adding temporalCov if that was not previously in the document
appears to fix the problem, although I haven't repeated it enough to be sure.

As an example, if you look at:

http://erizo.ucdavis.edu/metacat/

Document ID: dmk.16.21 appears blank, but if you do

http://erizo.ucdavis.edu/metacat/servlet/metacat?action=read&qformat=xml&docid=dmk.16.21

all of the information is there.

I haven't been able to find any significant EML differences that might explain
this. (And at the moment I can't fix dmk.16.21 despite several efforts).

History

#1 Updated by Dan Higgins about 17 years ago

Since the demonstration of this bug is with a web page rather than Morpho, there
would seem to be some question as to whether this is a Morpho bug or a Metacat
bug? (Morpho might have created the problem, but it seems to show up in the
Metacat code which creates ResultSet tables?) - Dan Higgins

#2 Updated by David Kaplan about 17 years ago

When you go to open the package in Morpho, it also shows the package without the
title, etc., so at least it is not a bug in how the information is displayed in
a browser. I am also not sure if it is morpho or metacat fundamentally, but I
had to choose one ...

I have found at least the immediate cause of the problem. Somehow all the
indexing information in xml_index regarding document dmk.16 is missing. If I
add some of the indexing information by hand, then that information appears
again in the package list (see my package list now for an example - the title
comes up, but the other information is absent because I didn't add all the
detailed indexing infor for that information). This suggests that the problem
lies in whatever code is responsible for updating index information on editing
(updating) a package. The information appears to be deleted OK, but no new
information is written.

The reason I put this as major is that I cannot find a solution to my problem
with this particular document short of generating the index information myself
by hand. Is there an easy way to force reindexing of a document?

#3 Updated by Dan Higgins about 17 years ago

Discussion with Jing indicate that this (the index problem) is a Metacat bug
that has already been fixed in the version of Metacat that is currently at the
head of CVS. (It has not been fixed in the currently released version.)

#4 Updated by Redmine Admin almost 8 years ago

Original Bugzilla ID was 1237

Also available in: Atom PDF