Project

General

Profile

Bug #1239

morpho fails when lastId gets out of sync

Added by David Kaplan almost 17 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
12/23/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1239

Description

I recently had to delete all the profile information that was contained in
.morpho. A new .morpho was created when I restarted morpho, but when I went to
"Add documentation" to a package it failed stating that id "dmk.1" was in use
already. The only way to fix this was to modify by hand the lastid in dmk.xml

History

#1 Updated by Dan Higgins almost 17 years ago

The setLastID method in the Morpho class is supposed to check with metacat for
the last ID. It seems to work fine for me when the entire .morpho directory is
discarded.

Need to look into this for more details.

#2 Updated by David Kaplan almost 17 years ago

I did delete the entire .morpho directory when this problem occurred. When does
it run setlastid? If it is only run when the original profile is created then
this could be part of the problem. I chose to skip login because I have to
change the metacat repository that it looks at before proceeding. Perhaps this
is the problem and why you don't see it. For you, the default repository works,
but for me it fails.

#3 Updated by ben leinfelder almost 8 years ago

Sounds like it correctly checked for the last id, but on a different server. At any rate, this is all different in v 2.0.0 not to mention ther large amount of identifier conflict resolution code that now exists.

#4 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 1239

Also available in: Atom PDF