Project

General

Profile

Bug #1461

dpw not adding role in associatedParty

Added by Chad Berkley about 18 years ago. Updated about 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
04/08/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1461

Description

when i try to validate a package after creating it and using one or more
referenced associatedParties, the package is invalid because there is no role
element in the associated Party. Here's the error:

Validation problem: Exception:cvc-complex-type.2.4.b: The content of element
'associatedParty' is not complete. It must match
'((((("":individualName)|("":organizationName)|("":positionName)){1-UNBOUNDED},
("":address){0-UNBOUNDED},("":phone){0-UNBOUNDED},("":electronicMailAddress) {0-UNBOUNDED},("":onlineUrl){0-UNBOUNDED},("":userId){0-UNBOUNDED})|
(("":references))),(("":role)))'.

the produced xml looks like:
<associatedParty>
<references>1081179008226</references>
</associatedParty>

it needs a <role> element inside associatedParty to be valid.

History

#1 Updated by Dan Higgins about 18 years ago

I have been unable to reproduce this bug in several attempts.

Perhaps the fix to Bug 1462 fixed this one?

#2 Updated by Chad Berkley about 18 years ago

ok, here are the steps to reproduce this bug:

1) start the dpw
2) enter an owner and contact (or select one from another package...it doesn't
matter)
3) go to the associatedParty screen
4) select one of the earlier entries for owner or contact to add as an assoc. party
5) click the check box to edit the entry
6) choose edit original
7) make a change to the assoc. party
8) finish the wizard, save the package and try to validate (just open it in the
editor then click save or try to save to metacat). you'll see there is no role
associated with the assoc. party reference.

#3 Updated by Dan Higgins about 18 years ago

with Chad's comments on how to reproduce this bug, I was able to figure out how
to fix it! (Dan)

Changed logic in how an edited reference was handled. Basically just made sure
the role string was saved and avoided rewriting the party when going back to the
summary page.

#4 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 1461

Also available in: Atom PDF