Project

General

Profile

Bug #1541

image display problem with image data from beta6 docs

Added by Dan Higgins about 15 years ago. Updated about 15 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
04/29/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1541

Description

Images that were saved as part of eml-beta6 packages do not display properly
after transformation to eml2 in Morpho 1.5 (reported by Cris Jones).

History

#1 Updated by Dan Higgins about 15 years ago

On Apr 28, 2004, at 10:34 AM, Christopher Jones wrote:

additional comments from Chris Jones:

The last EML2b6 bug I've seen is that morpho 1.5.0 won't render entitites that
were fake data tables used to show an image like a jpg. Again, sbclter.24.12
demonstrates this. The tabs that show the kelp bed images in morpho won't
render. I'll need to look into this, but I'm sure it's an XSL issue where the
'fake' metadata is juking morpho.

You can see that the three JPG entities in sbclter.24.12 in our catalog aren't
rendered correctly, but I haven't looked at the transformed EML yet to see why
it is.

#2 Updated by Dan Higgins about 15 years ago

This bug was NOT caused by the transformation, but rather by the way data files
associated with a beta6 package were loaded by morpho. To handle special
characters, there is a filter on xml files loaded from metacat and a new
'lopenDataFile' method for loading data files (which are treated as binaries).
This different way of loading data files had not been implemented for beta2
files, thus corrupting the jpg images. Problem corrected by changing the method
used to open beta6 data files.

#3 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 1541

Also available in: Atom PDF