Project

General

Profile

Bug #18

metacat docid and rootnodeid not generated in a safe manner

Added by Matt Jones over 19 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Jivka Bojilova
Category:
metacat
Target version:
Start date:
06/08/2000
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
18

Description

when a document or node are inserted into their respective tables, a trigger
generates an ID number for the PK from a SEQUENCE, which is then retreived by
examining the sequences "currval" attribute. If another db insertion was done
(by another user), then currval would return the wrong ID number. Basically,
need to return the generated ID number as part of the same transaction as the
insertion.

History

#1 Updated by Matt Jones over 19 years ago

Reassigned bug to bojilova. She will fix this bug by chnaging docid assignment
to the AccessionNumber class, and will find a fix for the problem when the
xml_nodes.nodeid is being assigned.

#2 Updated by Jivka Bojilova over 19 years ago

Problem fixed for docid assignment.
Using AccessionNumber class for docid generation from DBSAXDocument class.
Now docid is created in safe manner, because before with sequence
multiple user connections could get wrong currval from the sequence, ie not
their own.
xml_acc_numbers table keep track of docid values which are unique.
Accession # generation is runned in different connection with auto commit mode
in order to provide immediate visualization of the generated # to other user's
connections.

Need more work for nodeid - refer to bug #25 about safe nodeid generation
There are nothing about rootnodeid. The problem is for nodeid.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 18

Also available in: Atom PDF