Project

General

Profile

Bug #1819

Access control - deny public/allow user read: user couldn't read

Added by Veronique Connolly almost 15 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
registry
Target version:
Start date:
12/08/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1819

Description

I created three DPs for which I had set the Access Permissions so the public
would be denied access and I (uid=connolly,o=NCEAS,dc=ecoinformatics,dc=org)
would be allowed to read. When I tried accessing the data from the KNB web site
(after I logged in as uid=connolly,o=NCEAS,dc=ecoinformatics,dc=org), I got a
message saying "User public does not have permission to read the document".


Related issues

Blocks Metacat - Bug #1232: cookie needs to be written after knb page loginResolved12/05/2003

History

#1 Updated by Saurabh Garg almost 15 years ago

This is not a Morpho problem but a problem on the KNB skin.

#2 Updated by Saurabh Garg over 14 years ago

Changing the target milestone to release 1.6. Cant be included in 1.5 which has
to released soon.

#3 Updated by Saurabh Garg over 14 years ago

Changing the target milestone to release 1.6. Cant be included in 1.5 which has
to released soon.

#4 Updated by Saurabh Garg over 13 years ago

Merging into 1232

  • This bug has been marked as a duplicate of 1232 ***

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 1819

Also available in: Atom PDF