Project

General

Profile

Bug #2156

Metacat Performance: Send result back to web client in blocks

Added by Saurabh Garg over 14 years ago. Updated about 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
metacat
Target version:
Start date:
07/13/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2156

Description

Comparing Metacat with other search engines, there is a major
difference in the metacat web interface when compared to others. We
dont divide the result into blocks. So any online search will show x
number of results at a time. Metacat on the other hand shows all
results in one go. I am not sure how to fix this yet but I think we
will improve on time in three ways: database processing time, network
time and rendering of data in the browser. KNB currently has 1600
documents+ and a % search sends back a webpage which is 1.45 MB in
size. Hence even if we think of broadband, that is a lot of data being
sent back. Same goes for rendering of 1600 documents as compared to
10/20 documents. I am not sure though how hard this will be to implement


Related issues

Has duplicate Metacat - Bug #129: Metacat Performance: paged Query ReturnsClosed09/20/2000

History

#1 Updated by Saurabh Garg about 14 years ago

Duplicate of a much older bug entry.

  • This bug has been marked as a duplicate of 129 ***

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2156

Also available in: Atom PDF