Project

General

Profile

Bug #2281

Duplicated and incorrect search results in actor searching

Added by jianting zhang over 13 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
core
Target version:
Start date:
11/17/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2281

Description

The three actors "ENM PCP","ESRI Shapefile Displayer" and "GML Displayer" are
desinged to be GISOutputActor in the annotation file and correspon to "Outputs-
GIS" in the actor ontology. However, when search "GIS" in the actor search
panel, they appear both under "Inputs-External-GIS" and "Outputs-GIS". They
are not annotated to be the input actor by any means and the search results
are incorrect.

The problem happens because "GIS" is used in the two paths of the ontology
tree and the matching is based on the name of the path component. One simple
solution is to require unique names of ontlogy labels (which are used as the
naems of path components in the trees and ComposityEntity in the actor
library), but this may be not desirable.

The problem was covered before because there are no GIS actors that are
annotated as sole ouput actor (all the GIS output actors are also annotated as
input actors) before the check-in of the three actors.

Searching the current actor library using "GIS", the first search result
belongs to "Inputs-External-GIS" and ther are 6 actors (3 in only and 3
in/out) belong to it. When the first actor belongs to "Outputs-GIS" (3 out
only and 3 in/out), the ResultTreeBuilder.java set the container of "Outputs-
GIS" to "Inputs-External". After merging, there are 9 actors under "Inputs-
External-GIS" (3 in only, 3 in/out and 3 out only) as shown in the search
result.

History

#1 Updated by Chad Berkley over 13 years ago

the search is working correctly. The problem is the way the actors are
semantically tagged. If they are in a folder labeled 'GIS' then all actors will
show up when you search for 'gis'. if you don't want them to show up, move them
out of the GIS folder.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2281

Also available in: Atom PDF