Project

General

Profile

Bug #2304

RExpression accepts only limited input size.

Added by Lareo Lareo over 13 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
actors
Target version:
Start date:
11/30/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2304

Description

The R expression actor accepts only a very limited size of input. For example,
a vector x <- 1:20000 with 20000 elements cannot be in the input.
It was mentioned that it is planed to implement a TCP/IP binding to the R platform.
Maybe this binding does not have such limitation.

The bug is severe for the bioinformatics/microarray community. Here, dataframes
and tables of very large dimensions are handled.

History

#1 Updated by Dan Higgins over 13 years ago

I think I may have limited the size of the string used to pass data from Kepler
to R. (I will check the code.)
It may be very difficult to pass very large vectors from Kepler to R using the
current method of string conversions.

Dan Higgins - Nov 2005

#2 Updated by Dan Higgins over 13 years ago

Some further examination indicates that the problem indicate that the problem is
in 'R' rather than the RExpression code! (More precisely, an error occurs in
RTerminal when one tried to input too large of a vector.)

The problem is that vectors are passed a strings. The strings are broken into
many lines when the vestor is long. Apparently there is a limit in RTerminal in
the length of lines that can be put together to form an R expression (text limit
appears to be 128K?)

#3 Updated by Dan Higgins over 13 years ago

This bug was fixed by adding code to use temporary files for passing large
Kepler arrays to R. The R script automatically reads the file using 'scan' and
then deletes the temporary file.

Dan Higgins - Jan 2006

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2304

Also available in: Atom PDF