Project

General

Profile

Bug #2329

Summary Statistics Actor not working

Added by Dan Higgins over 13 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
actors
Target version:
Start date:
01/11/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2329

Description

The Summary Statistic actor is derived from the base RExpression actor. If this
actor is draged to the screen, the ports look right, but if you look at the
parameters, it shows an R script of '2+2' which is the RExpression default
rather than the script in the in the Summary Statistic xml! And if you hook it
up, it just runs the '2+2' rather than the correct script.

Dan Higgins - 1/11/2006

History

#1 Updated by Dan Higgins over 13 years ago

This problem looks like it is caused by a failure of the kar parser in the
ActorMetadata class. It looks like this class, which parses the moml in the kar
container simply does not reset actor parameters. (And Chad indicated that he
didn't realize that we needed to do that.)

The problem would apparently occur with any actor that might have parameterized
values (e.g. the R script), with each being saved as a separate distinct version
for the actor list.
Dan Higgins - 13Jan2006

#2 Updated by Dan Higgins over 13 years ago

The problem was traced to the ActorMetadata class. It runed out that this class
did not reset values of StringAttribute, Parameter, StringParameters (actually
any general Attibute) if the named attribute already existed. This is because a
NameDuplicationException is thrown if one tries to add an Attribute that already
exists.
The fix was to add code to getActorAsNamedObj to handle StringAttribute,
Parameter, StringParameters when they already exist in the container.

Dan Higgins - 1/20/2006

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2329

Also available in: Atom PDF