Project

General

Profile

Bug #2432

problems saving kars from saved actors

Added by Dan Higgins over 13 years ago. Updated over 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
05/02/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2432

Description

When saved RExperession actors or saved Composites are opened, they cannot be saved to the local KAR library. The key point is 'saved' If you build and configure these, they can be immediately saved as KARS. However, if first saved as workflows and then re-opened, you get a 'cannot save as KAR' message!


Related issues

Blocked by Kepler - Bug #2412: Unable to Create Kar file from compositeResolved04/12/2006

History

#1 Updated by Dan Higgins over 13 years ago

To reproduce the bug simply open workflows/eco/GARP_SingleSpecies_BestRuleSet.xml. Select the existing saved composite 'Calculate Best Rulesets' actor and try the 'Add to Library' menu command. When you fill in the dialog fields and execute, the "Error building the KAR file: Cannot create trasport KAR: null" appears.

[java] java.lang.NullPointerException
[java] at org.kepler.ksw.KSWBuilder.createKSW(KSWBuilder.java:225)
[java] at org.kepler.ksw.KSWBuilder.createTransportKSW(KSWBuilder.java:
182)
[java] at org.kepler.ksw.KSWBuilder.<init>(KSWBuilder.java:132)
[java] at org.kepler.ksw.KSWBuilder.<init>(KSWBuilder.java:95)
[java] at org.kepler.ksw.gui.CreateKSWDialog$1.actionPerformed(CreateKS
WDialog.java:181)
...

Same thing happens with modified RExpression actors that have been saved to files and then reopened, while composites and modified actors that have never been saved seem to work.

#2 Updated by Chad Berkley over 13 years ago

The reason for this appears to be that the "create composite" menu item was used to create the "Calculate Best Rulesets" composite and thus is does not have an entityId attribute (or any of the other kepler required attributes).

I was not able to reproduce this with an RExpression actor. I created a new workflow, drug an RExpression actor to the canvas, modified the RExpression actor, saved the workflow, closed the workflow, reopened the workflow, then ran "add to library" and it worked fine. The only reason you should get an NPE is if one of the kepler required properties do not exist in the actor. The error handling could probably be a bit better.

I'll leave this bug open for now. If you find another way to reproduce it, add the sequence here and I'll take a look.

#3 Updated by Dan Higgins over 12 years ago

Looks like this bug has been fixed in latest version of Kepler

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2432

Also available in: Atom PDF