Project

General

Profile

Bug #2462

Can't delete columns toward end of table

Added by Will Tyburczy over 13 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
06/15/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2462

Description

So far, I have only experienced this behavior with dp bowdish.131, but the document parses fine.

To re-create this bug, open dp bowdish.131 (you will need to be a member of knb-prod to do this). Now, right click in one of the last 5 columns and select "Delete Selected Column". You will notice that nothing will change visibly
(This is the gist of the problem, what follows is just trying to explore what has happened).

If you now select the column that should have been deleted, you will see that the information displayed on the right does not match the column header, as if the metadata for that column had been deleted, even though the column header hasn't changed.

If you go into the tree editor at this point, you will see that the metadata for the column has been deleted. Click "OK" to exit, and the column header for the "deleted" column will no longer be there, but the data will still be present, and the column headers will be one off from the column data.


Related issues

Has duplicate Morpho - Bug #2463: Morpho can't delete or insert columns at right edge of tables with uneven record lengthsNew06/16/2006

History

#1 Updated by Will Tyburczy over 13 years ago

Checking stderr.log, the error looks like:

Exception in thread "AWT-EventQueue-0" java.lang.ArrayIndexOutOfBoundsException: 25 >= 23
at java.util.Vector.removeElementAt(Vector.java:518)
at edu.ucsb.nceas.morpho.datapackage.PersistentTableModel.deleteColumn(PersistentTableModel.java:404)
at edu.ucsb.nceas.morpho.datapackage.DeleteColumnCommand.deleteColumn(DeleteColumnCommand.java:121)
at edu.ucsb.nceas.morpho.datapackage.DeleteColumnCommand.execute(DeleteColumnCommand.java:92)
at edu.ucsb.nceas.morpho.util.GUIAction.actionPerformed(GUIAction.java:410)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1882)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2202)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
at javax.swing.AbstractButton.doClick(AbstractButton.java:334)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1000)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1041)
at java.awt.Component.processMouseEvent(Component.java:5554)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
at java.awt.Component.processEvent(Component.java:5319)
at java.awt.Container.processEvent(Container.java:2010)
at java.awt.Component.dispatchEventImpl(Component.java:4021)
at java.awt.Container.dispatchEventImpl(Container.java:2068)
at java.awt.Component.dispatchEvent(Component.java:3869)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3936)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3866)
at java.awt.Container.dispatchEventImpl(Container.java:2054)
at java.awt.Window.dispatchEventImpl(Window.java:1774)
at java.awt.Component.dispatchEvent(Component.java:3869)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

#2 Updated by Will Tyburczy over 13 years ago

This bug seems to stem from trying to delete the values in the actual data file. If you remove the data file from the .morpho directory, you can delete columns from the dp normally.

#3 Updated by Will Tyburczy over 13 years ago

Found out why this particular table was misbehaving. See the duplicate bug for the problem.

  • This bug has been marked as a duplicate of 2463 ***

#4 Updated by Jing Tao over 10 years ago

move to 1.7

#5 Updated by Redmine Admin almost 7 years ago

Original Bugzilla ID was 2462

Also available in: Atom PDF