Project

General

Profile

Bug #2471

'Upload to Repository' menu throws an error

Added by Dan Higgins over 13 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
06/26/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2471

Description

Attempts to use the 'Upload to Repository' popup menu throws the error

[java] repository initialized with put server: http://library.kepler-projec
t.org/kepler/services/EcogridPutService
[java] repository initialized with auth server: http://library.kepler-proje
ct.org/kepler/services/EcoGridAuthLevelOneService
[java] repository initialized with lsid server: http://library.kepler-proje
ct.org/ecogrid-identifier/services/EcoGridIdentifierService
[java] AxisFault
[java] faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userEx
ception
[java] faultSubcode:
[java] faultString: java.rmi.RemoteException: Error getting next object fo
r lsid urn:lsid:kepler-project.org:kar:1:1: No attributes are implemented
[java] faultActor:
[java] faultNode:
[java] faultDetail:
[java] {http://xml.apache.org/axis/}hostname:knb.msi.ucsb.edu
[java] java.rmi.RemoteException: Error getting next object for lsid urn:lsi
d:kepler-project.org:kar:1:1: No attributes are implemented
[java] at org.apache.axis.message.SOAPFaultBuilder.createFault(SOAPFaul
tBuilder.java:222)

Note that this problem occurs in both the Beta1 release and the current (6/26) head of CVS

History

#1 Updated by Dan Higgins over 13 years ago

Further examination of the error message here suggests that the problem is on the server side rather than in the Kepler code!
Dan Higgins

#2 Updated by Dan Higgins over 13 years ago

Jing discovered that this was a server error apparently due to an update of the xerces jar on the server. commenting out one setting for xerces removed the problem.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2471

Also available in: Atom PDF