Project

General

Profile

Bug #260

acl handling for packages needs to be updated

Added by Chad Berkley over 19 years ago. Updated over 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
07/24/2001
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
260

Description

the package editor components now need to update an acl file for public read
write access instead of setting the public boolean in the URL.

History

#1 Updated by Chad Berkley about 19 years ago

I am going to hold off on this bug until after we decide what our different
relationships should be. The problem is, that without scanning every file in a
package looking for a specific publicid (that will probably change) I can't be
sure what file is the access file, so I can't update it (if it already exists).
This will be made much easier one we come up with a discreet set of
relationships in the triples so that I can go straight to the file without
looking at publicids.

#2 Updated by Chad Berkley about 19 years ago

changed the functionality in morpho so that the whole package is always governed
by one access file. the access file can be changed to reassign permissions at
the packag level. later, we will need to create a gui for assigning permissions
to individual document in the package if we decide we need that functionality.

#3 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 260

Also available in: Atom PDF