Project

General

Profile

Bug #2713

Figure out the emailing strategy for CVS emails

Added by Michael Lee over 13 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
misc
Target version:
Start date:
01/04/2007
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2713

Description

We currently have an alias (cvs(at)unc-dot-edu) that points to michael's unc email address. This is difficult to manage in that
1) it only goes to one person (So if they are on vacation, swamped by email, accidentally delete it, we respond slowly or not at all or lose something).
2) there is no archive
3) it's hard to change who it goes to (michael has to release the alias then someone else has to grab it, hoping no one else gets it first!)

---
So, we could use a listserv, which we could setup at UNC, such as . Potential Problems there:
1) private lists are not archived; public lists could get members added (we'd want to avoid that)
2) The is an awkward email address, so perhaps we could alias it somehow
3) listserv emails are limited to 5MB attachments (too small for our purposes, perhaps we could get some listserv admin to change that for us).
4) a 12MB file would go to all of michael, forbes, bob, and maybe steve, which results in 48MB of email, plus perhaps something in the archive. This begs for an FTP system that results in only one upload of the file, perhaps married to a listserv system that would alert us to the successful upload of a new package to the FTP server.

What are our FTP options at UNC, Bob? Can we set up something like that easily. We could have a backup of using the existing alias if the ftp doesn't work for someone, with a separate (perhaps automated) email to let cvsdata listserv know.

History

#1 Updated by Robert Peet over 13 years ago

I have verified that we can point an alias at a listserv.

I am sure we can find a way to set up an anonymous write-only ftp service here in Biology, but it seems like we would want GUI where you can navigate to the file on your home machine and then push an upload button. Mike, is this something that you could create. I know Xianhua did this for the Peer Review tool part of the VegBank project, and has it running off his desktop here in Coker. We could ask him about it perhaps, if needed.

#2 Updated by Michael Lee over 13 years ago

The list has been created. We three (Bob, Forbes, Michael) are members and all have administrative rights.

This still will presumably not accept attachments over 5MB (I can test that, too)

#3 Updated by Michael Lee over 13 years ago

attachments over 5MB have failed, as expected to the list. The alias cvs (at) unc.edu does point to this list, so that's good. If we can get larger attachments (at least 15MB, probably better to have even more), then this system will work, otherwise we need some ftp options.

#4 Updated by Michael Lee over 13 years ago

Bob emails on 1/8/2007:

I have just confirmed that we cannot relax the 5M cap on email sent to

Hinar is willing to set up an anonymous ftp site on Bioark. I think he
can get it done within the week. If we want a fancy shell around it to
make it more friendly and send us automated email, we will have to build
it ourselves. Shall we give ftp a chance? I am not sure how simple we
can make the directions without the shell. The alternative is simply to
email one of us with an attachment.

Michael chimes in:
I think we should try FTP and see if that will work, and if so use it. Otherwise we fall back on emails to one of us. Perhaps another alias could be used () which could get configured to whoever needs to receive such emails.

#5 Updated by Michael Lee over 13 years ago

An FTP solution has been established:

Proposed directions for uploading EEP data to CVS:

1. Name your dataentry tool file as Firm-Year-SequenceLetter.mdb. [preferably .zip as files should be zipped]
For example, a file named WeedsRus-2007-A.mdb would fit the format. The
intent of the name design is to identify your specific file and to prevent
two files from having the same name and thereby having one submission
overwrite another.

2. Open Windows Explorer (not Internet Explorer), often called "My
computer"

3. In the "Address:" line, erase the contents (e.g., My Computer) and
enter the following: ftp://ftp.bio.unc.edu

4. When prompted enter userid = [deleted!] and password = [deleted!]

5. Drag and drop your data file into windows explorer. Note that at first
you will see your file name, but that once you refresh your screen or look
again, it will be gone - do not take this as a reason to try again. The
file name vanishes because you do not have permission to read the
directory

6. Send an email to announcing that you have delivered your
data. Backup, if that doesn't work, send e-mail to with the attached zipped database.

#6 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 2713

Also available in: Atom PDF