Project

General

Profile

Bug #2940

Querybuilder with EMLDatasource actor does not return data

Added by ben leinfelder about 12 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
data access
Target version:
Start date:
09/06/2007
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2940

Description

See attached workflow for example.
When querybuilder interface is used to limit the columns/records nothing is returned.
When the actor is first dragged to the canvas (w/o specifying filters) data is returned.

eml_querybuilder_bug.xml (47.9 KB) eml_querybuilder_bug.xml ben leinfelder, 09/06/2007 03:16 PM

History

#2 Updated by Dan Higgins about 12 years ago

This does not appear to be a general problem with QueryBuilder since it does work when a single EML2 datasource is dragged to the screen. (Dan Higgins)

#3 Updated by Dan Higgins about 12 years ago

I need to amend previous comment. QueryBuilder seems to work when there is a SINGLE table associated with the dataset!

#4 Updated by Jing Tao over 11 years ago

This problem wasn't caused by multiple tables or single table. Actually there is a space in attribute name cause the problem - illegal db attribute name (with a space between two word). I added a new method to transfer space to underscore. It fixed the problem. The attached workflow now works.

#5 Updated by Jing Tao over 11 years ago

Ben tried the workflow and it worked for him too.

#6 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2940

Also available in: Atom PDF