Project

General

Profile

Bug #2958

RExpression actor problem with large string arrays

Added by Dan Higgins over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
actors
Target version:
Start date:
09/10/2007
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2958

Description

Currently the RExpression actor handles very large arrays of input by means of an intermediate file that is read using the R 'scan' function. (Strings are used as input for smaller arrays, but the input system of R can only handle a limited size). Kevin Drury reported a problem, however, with a large string array.

The problem is the the 'scan' function defaults to numeric values. The RExpression actor code needs to be fixed to handle large string arrays that a placed in an intermediate file. (It seems to work OK for large numeric strings, and for small string arrays not written to a file.)

History

#1 Updated by Dan Higgins over 11 years ago

Problem has been fixed by checking for large string arrays

#2 Updated by Redmine Admin almost 6 years ago

Original Bugzilla ID was 2958

Also available in: Atom PDF