Project

General

Profile

Bug #2961

Include option in EMLDatasource actor to use 'most recent' data

Added by ben leinfelder about 12 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Category:
data access
Target version:
Start date:
09/11/2007
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2961

Description

Change EMLDatasource actor to allow user to specify 'most recent version' of package data be used.
On workflow open?/execution?, actor will check the [remote] source for latest version of the data, fetch it and use that for the run.
Will need to be careful of schema/structure changes to the data tables.

History

#1 Updated by ben leinfelder almost 12 years ago

Added check to EML200Datasource actor.
Uses RepositoryManager to make webservice call to earthgrid.
Still need to refactor the services to use the object manager method of managing eco/earthgrid services. essentially need to have the search and selectable stuff in the classes that extend Repository.

#2 Updated by ben leinfelder over 11 years ago

with the changes to how ecogrid can be searched using authentication credentials, i've also changed how the eml actor checks for the latest version.
Services can now be related to each other by sharing the same "clusterName" - given a queryservice, we can find the appropriate identifierservice to use for looking up the latest version of the metadata/data.

#3 Updated by ben leinfelder over 11 years ago

this change has been included in RC1

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2961

Also available in: Atom PDF