Project

General

Profile

Bug #2977

change "add party" dialog to do so more cleanly

Added by Michael Lee about 13 years ago. Updated about 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
EntryDB
Target version:
Start date:
10/08/2007
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2977

Description

The party should be automatically added, with a beep. A new form should appear under the current forms with "New parties recently added." and an opportunity to fill out more info for any of them. Can use bln_newRec and min party_ID that is set. Each time an additional party is added, just requery it.

Too many questions currently and the answer isn't entirely obvious. Do you have more info? yes/no/cancel.

To delete party, there could be a button there. Would need to check that all obsContribs of that party don't exist- perhaps toggle to a different person before delete. Add combine party feature?


Related issues

Is duplicate of InfoVeg - Bug #2922: Use non-modal messages when adding new partiesResolved09/01/2007

History

#1 Updated by Michael Lee about 13 years ago

A helpful site for multiple instances of forms, but I don't know if that's really needed. One form should suffice.

#2 Updated by Michael Lee about 13 years ago

looks like I forgot to list the helpful site in the above comment.

#3 Updated by Michael Lee about 13 years ago

  • Bug 2922 has been marked as a duplicate of this bug. ***

#4 Updated by Michael Lee about 13 years ago

Perhaps Gmail-ish, where it says "you have added party X" and there would be an
"undo" link at the same place.

#5 Updated by Michael Lee about 13 years ago

(In reply to comment #1)

A helpful site for multiple instances of forms, but I don't know if that's
really needed. One form should suffice.

here it is:
http://ewbi.blogs.com/develops/2003/09/multiple_instan.html

#6 Updated by Michael Lee about 13 years ago

fixed, v221_p3_post.zip

This is MUCH MUCH nicer than the previous interrogation.

#7 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 2977

Also available in: Atom PDF