Project

General

Profile

Bug #3169

Cannot add documentation to a new actor from within Kepler

Added by Dan Higgins over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
actors
Target version:
Start date:
02/29/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3169

Description

If one instantiates a new actor, it can be added to the library or saved as a KAR, but there is no way to add documentation from within Kepler!

If there is no current documentation, the Documentation/Customize menu item does nothing. So there is no way to add documentation other than adding it directly to the actor moml.

Dan HIggins - 29 Feb 2008

History

#1 Updated by Chad Berkley over 11 years ago

Oops, I meant to add that feature but forgot. I'll add it now. Thanks for finding it, Dan.

#2 Updated by Chad Berkley over 11 years ago

I fixed a bug where the documentation would not show if a value in the moml was null. This fix was in the PTII tree so if you want to see the bug fix, you have to update ptII.

Dan, can you provide more information on how you made an actor without the KeplerDocumentation Attribute? Could you give me a step-by-step on what you did so I can reproduce it? thanks.

#3 Updated by Dan Higgins over 11 years ago

Chad,
Creating and actor without the KeplerDocumentation Attribute is as simple as creating a new Java coded actor and adding to a workflow using the Tools/Instantiate Component menu item. I originally did this with the AscGridValue actor, but I think Kirsten has now added the documentation.

Another actor(s) that you can load is/are the Python actors (which are currently in the Kepler src but not in the the actor library. From Kepler, you can just open a Ptolemy moml file to instantiate the actors. Open $PTII/ptolemy/actror/lib/python/python.xml. This should create a workflow with 2 actors - PythonActor and PythonScript. These actors have no documentation information.
I am particulatrly interested in these actors because I am hoping to add them to Kepler with documentation. (I have been getting better acquainted with Python/Jython and think that adding such scripting actors to Kepler would be useful for a lot of users.)

Dan Higgins - 3 Mar 2008

#4 Updated by Chad Berkley over 11 years ago

This now works. You can click customize and even if there is no current documentation, a blank documentation window will show up. I also added a kepler specific error message to the "display documentation" action to tell the user that there is no documentation specified and that they can click the customize option to create some.

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3169

Also available in: Atom PDF