Project

General

Profile

Bug #3209

ecogrid SearchRegistryAction error when disconnected from network

Added by Daniel Crawl about 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
04/04/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3209

Description

About 30 seconds after starting kepler with no network connection, a long error
message is displayed, starting with:

[java] ERROR (org.ecoinformatics.seek.ecogrid.SearchRegistryAction:queryRegistryRewriteConfig:210) problem looking up registry entries using endpoint: http://knb.ecoinformatics.org/registry/services/RegistryService

Most likely caused by the fix for 3124.
http://bugzilla.ecoinformatics.org/show_bug.cgi?id=3124

History

#1 Updated by ben leinfelder about 11 years ago

sounds like some error catching is in order. should there be an alert using MessageHandler (attack of the pop up window!) or should it just log the error and move on with life?

#2 Updated by Daniel Crawl about 11 years ago

I'd say show an alert when something is trying to use a data source, e.g. the ecogrid actor. Otherwise, ignore it.

#3 Updated by ben leinfelder about 11 years ago

added messagehandler error reporting when the services registry is not available.
if, on start up, there is an error accessing the registry, an alert is shown (in kepler gui mode, at least).

#4 Updated by Daniel Crawl about 11 years ago

I'm reopening this since the error window now occurs regardless of any data sources actually being used (either the Data tab or ecogrid actors).

This seems low priority so could be re-targeted to 1.1.

#5 Updated by Chad Berkley about 11 years ago

retarget to 1.1

#6 Updated by Jing Tao about 11 years ago

The short term solution is just removing the error message. Kepler will keep silent if it couldn't connect to the registry.

The long term solution is assigned to bug 3228.

#7 Updated by Jing Tao about 11 years ago

Remove the error message panel and decrease debug level from error to warn in src/org/ecoinformatics/seek/ecogrid/SearchRegistryAction.java class. Now if kepler couldn't contact registry because of network disconnection and it will keep silence.

#8 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 3209

Also available in: Atom PDF