Project

General

Profile

Bug #3269

authentication system throws NPE

Added by Chad Berkley about 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
core
Target version:
Start date:
05/02/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3269

Description

after a fresh install, go to the data tab. remove the digir selection, search for 'datos'. click the 'login anonymously' button when prompted. you'll get a search result.

restart kepler

do the same thing. you'll get an NPE traced to AuthenticationManager.getProxy() line 124.


Related issues

Blocked by Kepler - Bug #3245: Release 1.0 installer tracking bugResolved04/29/2008

Blocked by Kepler - Bug #3271: Random Errors with data authentication systemResolved05/02/2008

History

#1 Updated by ben leinfelder about 11 years ago

is there a reason we have the "login anonymously" button?
i believe it is an artifact of functionality that is no longer used. what is the use for the "kepler/kepler" user account?
i propose removing that button from the release if no one is using it for something.

#2 Updated by Chad Berkley about 11 years ago

The login anonymously is needed for the kepler component repository. It's there so that people don't have to have a user account in order to upload components to the repository. unless we're going to require people to have usernames to use the repository, it should stay.

#3 Updated by ben leinfelder about 11 years ago

i can recreate this error in the installer version of kepler, but not in my local development version (using release tag).

#4 Updated by Chad Berkley about 11 years ago

this now works in the cvs branch and in a new installer i just created. closing this bug.

#5 Updated by ben leinfelder about 11 years ago

actually found that this bug still existed as an artifact of multiple login dialogues appearing when concurrent threads were requesting auth credentials. it can remain closed, but I wanted to comment on it.
cvs commit message is such:
"change the LDAP login gui to use a singleton patter rather than a static method pattern so that displaying the login dialogue can be a synchronized process (in cases when requests for authentication are happening in concurrent threads as with the ecogrid searches and retrievals)."

#6 Updated by ben leinfelder about 11 years ago

works on ubuntu (v3 installer)

#7 Updated by Aaron Aaron about 11 years ago

Works on win v3 installer.

On mac when I did the search a second time, after restarting kepler, it hangs for a long time. So I cancelled. Then I restarted and tried a third time and got an AuthenticationException error with a hung "Progress" bar.
Then I installed a fresh v3 on mac (deleted jar installer, application and .kepler directory then downloaded and installed v3 with R again). Set sources to KNB Metacat Query Interface and KNB Metacat Authenticated Query Interface like I had before and searched for datos. And it worked fine the first time. Then I exited kepler and started it back up and did the same thing and waited 14.5 minutes on a blank "KNB - LDAP Login" screen before I gave up and quit. Then tried a third time again and got the same error as before
org.kepler.authentication.AuthenticationException at org.kepler.authentication.AuthenticationManager.getProxy(AuthenticationManager.java:124)

#8 Updated by ben leinfelder about 11 years ago

Was able to see the errors on my local workspace version (thank goodness). I've added synchronized to the EcogridservicesController where authentication is being kicked off - this seems to have resolved the thread contention (and errors) for my local checkout. If others (aaron) could check these changes locally before creating more installers, that would be great.

#9 Updated by Aaron Aaron about 11 years ago

Looks ok here, we'll see what happens in the next installer...

#10 Updated by Jing Tao about 11 years ago

It worked fine in mac v4 installer.

#11 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 3269

Also available in: Atom PDF