Project

General

Profile

Bug #3397

metacat needs server side sort mechanism

Added by Chad Berkley over 11 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
metacat
Target version:
Start date:
06/16/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3397

Description

in the past, we've been using xslt to sort search results going to a browser or client. This works fine until you use paged search results when you need the results sorted before the paging takes place. we need to add functionality to give the server an attribute to sort on before it pages the results. this should probably work similar to the returnfields mechanism (or with the returnfields mechanism).


Related issues

Is duplicate of Metacat - Bug #3413: Sort order of returned resultsets needs to be standardResolved06/23/2008

History

#1 Updated by Chad Berkley over 11 years ago

  • Bug 3413 has been marked as a duplicate of this bug. ***

#2 Updated by Jing Tao over 11 years ago

Move to 1.9 milestone

#3 Updated by ben leinfelder over 6 years ago

This should come with the SOLR implementation.

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3397

#5 Updated by ben leinfelder over 6 years ago

  • Status changed from New to Resolved

SOLR queries can specify a sort field 9or even a function!) - we will not implement this in pathquery.

Also available in: Atom PDF