Project

General

Profile

Bug #3851

Problem when building a package with the new system

Added by Luca Clementi over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
build system
Target version:
Start date:
02/27/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3851

Description

I'm having some problem in creating a package with kepler.

So from the build-area I'm executing:
ant package -Dsuite=kepler-trunk
then I unzip the package created in module/kepler-trunk.zip

When I try to run the jar I get the error reported below.

Luca

clem@lhc:~/projects/opal/kepler/kepler/modules/temp$ java jar kepler-trunk.jar
run.perform()
Exception in thread "main" java.lang.NullPointerException
at org.kepler.core.ant.common.CommonBuildTask.execute(CommonBuildTask.java:42)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.kepler.core.runner.Kepler.main(Kepler.java:51)
Caused by: java.lang.NullPointerException
at org.kepler.core.ant.Run.handleRunProperties(Run.java:181)
at org.kepler.core.ant.Run.runSuite(Run.java:166)
at org.kepler.core.ant.Run.run(Run.java:136)
at org.kepler.core.ant.common.CommonBuildTask.execute(CommonBuildTask.java:38)
... 7 more
--
Nested Exception ---
java.lang.NullPointerException
at org.kepler.core.ant.Run.handleRunProperties(Run.java:181)
at org.kepler.core.ant.Run.runSuite(Run.java:166)
at org.kepler.core.ant.Run.run(Run.java:136)
at org.kepler.core.ant.common.CommonBuildTask.execute(CommonBuildTask.java:38)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.kepler.core.runner.Kepler.main(Kepler.java:51)

History

#1 Updated by David Welker over 10 years ago

This bug has been fixed for some time. I just tested the functionality of the package command with kepler-trunk, and it worked fine.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3851

Also available in: Atom PDF