Project

General

Profile

Bug #3928

Support multiple administrators ACL rules in editing existing documents

Added by Shaun Walbridge over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
registry
Target version:
Start date:
04/01/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3928

Description

This document is throwing and ACL error when trying to edit it:
http://knb.ecoinformatics.org/knb/metacat?action=read&qformat=nceas&docid=nceas.956.1

all auth.moderators have been added to the document, which is a change from the previous choice of only supporting the skin moderator. Either prevent these from being added by default, or remove the ACL error on creation (check the names against the auth.moderators list).

History

#1 Updated by Shaun Walbridge over 10 years ago

The issue isn't actually with auth.moderators, though we will want to either change the behavior to not include everyone in this list, or remove the other moderators from production KNB (it is certainly wrong to have the ESA moderator on every NCEAS package). The actual problem is just error reporting: if you try editing a document which you don't have permission to edit, you'll get this error instead of a message indicating your lack of access and information about who has access.

A straightforward fix would be to include the contact information for the first creator (//dataset/creator/individualName) in the returned error message, or at least a 'no access to edit' message. Better yet, fix the listing view to prevent the 'edit' button from showing up in all the listings...

#2 Updated by Shaun Walbridge over 10 years ago

Fixed in r4905, with a relatively simple fix: displays the LDAP string of the document owner instead of the bogus Morpho ACL message.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3928

Also available in: Atom PDF