Project

General

Profile

Bug #4284

Unable to download student response data from the EGR server via FIRST website

Added by Sandeep Namilikonda over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Immediate
Category:
dataserver
Target version:
Start date:
08/06/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4284

Description

While using http://www.egr.msu.edu/first website, we noticed that a user is able
to browse through various assessments that have been uploaded, add any assessment of interest to the data cart, and also view the assessment items by clicking the "details" tab. But, when we try to download the student response data corresponding to the assessment as a ".csv" file, the download seldom takes place for assessments of reasonable size. For example, Jay had uploaded two
assessments called "2005 Fall Exam 2" and "2002 Fall Final" with 396 students and 50 questions (items) and 8 students and 84 items, respectively. With both of these assessments, when the user clicks the download link,
after a large amount of waiting time, probably 5-10 minutes, the server eventually displays a blank page with the URL ending in download.jsp.

On the other hand, a couple of test assessments, one with 14 students and 3 items and other with 2 students and 2 items, the download feature worked fine
although a significant delay was noticed when Ryan tried to download them on his computer using a Firefox browser.

History

#1 Updated by ben leinfelder over 10 years ago

I've gotten access to the Tomcat log files - but now to trace it down further I'd like to get the data uploaded to my server here in Santa Barbara.
You can set your Morpho Preerences to use the Metacat URL:
http://fred.msi.ucsb.edu:8080/knb/metacat
and save to that server that would be very helpful. That way i can step through debugging what exactly is going on.

#2 Updated by ben leinfelder over 10 years ago

Moved the data to my development machine:
turns out the query was throwing an error when questions didn't all have the same number of choices (multiple choice) - not such a fringe case, you'd think!
Fixed that.
Redeployed to EGR.
Downloaded "2002 Fall Final" successfully (but yes, it takes a while)

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4284

Also available in: Atom PDF