Project

General

Profile

Bug #434

Copying root nodes in XML editor

Added by Dan Higgins over 17 years ago. Updated over 15 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
02/19/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
434

Description

The Morpho XML editor allows the copying and pasting of tree nodes (and their
children). Currently, copying the root node does not work, however. This would
be very useful, however, in cases like eml-attribute documents where there are
many attribte nodes directly under the root and one wishes to copy all of them
to a new document.

A simple replacement of the root node with a new root is easily implementsed.
The problem is that this approach also copies identifier nodes. We thus need to
put the old identifier back into the new identifier nodes.

History

#1 Updated by Dan Higgins over 15 years ago

This problem essentially disappears with the eml2 editor, since what were
different modules are now subtrees in a single document. Any of these can be
copied from one document to another.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 434

Also available in: Atom PDF