Project

General

Profile

Bug #4384

"Browse All Assessments" on FIRST website generates http error prior to login

Added by Sandeep Namilikonda about 10 years ago. Updated about 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
dataserver
Target version:
Start date:
09/14/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4384

Description

On http://www.egr.msu.edu/first/, when a user clicks on the
"Browse All Assessments" link prior to logging in, the server generates the
following error in a pop-up window: "failure making ajax call" followed by the
following message on the page:

HTTP Status 500 -

type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception
java.lang.NullPointerException
edu.ucsb.nceas.metacat.MetaCatServlet.handleGetOrPost(MetaCatServlet.java:843)
edu.ucsb.nceas.metacat.MetaCatServlet.doPost(MetaCatServlet.java:521)
javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
org.vfny.geoserver.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:122)
note The full stack trace of the root cause is available in the Apache Tomcat/6.0.18 logs.

Note that this functionality was previously working fine. We have consistently noticed this behavior on various browsers.

History

#1 Updated by Matt Jones about 10 years ago

I've verified that this bug happens for me as well when not logged in, but is not encountered after logging in. Looking at the Metacat code, it appears that the sessionData object below is null before logging in.

} else {
SessionData sessionData = RequestUtil.getSessionData(request);

843 ---> userName = sessionData.getUserName();
password = sessionData.getPassword();
groupNames = sessionData.getGroupNames();
sessionId = sessionData.getId();

logMetacat.info("The user is : " + userName);
}

#2 Updated by ben leinfelder about 10 years ago

i'll check with Mike and see what's going on in this case. He's actively been developing in the area of sessions/users etc...

#3 Updated by ben leinfelder about 10 years ago

i just tried this and received no error. 11 assessments were returned when not logged in. I am using FF 3.5.3

#4 Updated by ben leinfelder about 10 years ago

reopen if this occurs again

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4384

Also available in: Atom PDF