Project

General

Profile

Bug #4449

exception when dragging workflow

Added by Chad Berkley over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
interface
Target version:
Start date:
10/14/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4449

Description

I get the following exception when trying to drag a workflow to the canvas from the workflows folder after saving a kar.

com.microstar.xml.XmlException: Cannot create entity without a class name. in [external stream] at line 2 and column 31
at ptolemy.moml.MoMLParser._checkForNull(MoMLParser.java:3794)
at ptolemy.moml.MoMLParser._createEntity(MoMLParser.java:3975)
at ptolemy.moml.MoMLParser.startElement(MoMLParser.java:2495)
at com.microstar.xml.XmlParser.parseElement(XmlParser.java:921)
at com.microstar.xml.XmlParser.parseContent(XmlParser.java:1104)
at com.microstar.xml.XmlParser.parseElement(XmlParser.java:924)
at com.microstar.xml.XmlParser.parseContent(XmlParser.java:1104)
at com.microstar.xml.XmlParser.parseElement(XmlParser.java:924)
at com.microstar.xml.XmlParser.parseDocument(XmlParser.java:481)
at com.microstar.xml.XmlParser.doParse(XmlParser.java:159)
at com.microstar.xml.XmlParser.parse(XmlParser.java:132)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1404)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1376)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1532)
at ptolemy.moml.MoMLChangeRequest._execute(MoMLChangeRequest.java:270)
at ptolemy.kernel.util.ChangeRequest.execute(ChangeRequest.java:171)
at ptolemy.kernel.util.NamedObj.executeChangeRequests(NamedObj.java:727)
at ptolemy.kernel.util.NamedObj.requestChange(NamedObj.java:1752)
at ptolemy.actor.CompositeActor.requestChange(CompositeActor.java:1468)
at ptolemy.vergil.basic.EditorDropTarget$DTListener.drop(EditorDropTarget.java:450)
at java.awt.dnd.DropTarget.drop(DropTarget.java:430)
at sun.awt.dnd.SunDropTargetContextPeer.processDropMessage(SunDropTargetContextPeer.java:500)
at sun.awt.dnd.SunDropTargetContextPeer.access$800(SunDropTargetContextPeer.java:53)
at sun.awt.dnd.SunDropTargetContextPeer$EventDispatcher.dispatchDropEvent(SunDropTargetContextPeer.java:812)
at sun.awt.dnd.SunDropTargetContextPeer$EventDispatcher.dispatchEvent(SunDropTargetContextPeer.java:736)
at sun.awt.dnd.SunDropTargetEvent.dispatch(SunDropTargetEvent.java:29)
at java.awt.Component.dispatchEventImpl(Component.java:3926)
at java.awt.Container.dispatchEventImpl(Container.java:2068)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
at java.awt.LightweightDispatcher.processDropTargetEvent(Container.java:4007)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3861)
at java.awt.Container.dispatchEventImpl(Container.java:2054)
at java.awt.Window.dispatchEventImpl(Window.java:1801)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

History

#1 Updated by Aaron Aaron over 9 years ago

I am unable to reproduce this. Can you give more detail on how to reproduce this? What actors you're using, what OS, what suite/modules, what java version, etc...? Thanks

#2 Updated by Aaron Aaron over 9 years ago

I'm not seeing this... closing for now

#3 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4449

Also available in: Atom PDF