Project

General

Profile

Bug #4677

Windows 7 installer/testing

Added by ben leinfelder almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
01/15/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4677

Description

Make sure Morpho installs and runs on Windows 7

History

#1 Updated by Jing Tao almost 10 years ago

Morpho installer couldn't be installed under c:\program files folder. Other than this, it worked. But morpho can be installed under c:\program files folder on Vista. It was an issue on vista as well.

#2 Updated by Jing Tao almost 10 years ago

Here is the story:

During the installation on windows 7, the installer told me that it didn't have the permission to create a new folder under c:\program files if I selected it as the destination folder. I had to choose another one, e.g., the user's home folder. After I chose the home folder, the installer installed morpho successfully. And morpho was running smoothly.

I had the same experience with window vista on the previous release. I managed to figure it out. Current morpho installer can install morpho under c:\program files on Vista successfully.

I will take a look to see how to fix the issue.

#3 Updated by Jing Tao almost 10 years ago

In installer/build/install-windows.xml, there is element named run-privileged. It can make the installer attempt to launch itself with administrator permissions. In previous version, an attribute named condition has the value - vista. This means that it only work for vista. After removing the condition, it works with windows 7.

I tried to install and uninstall morpho on windows xp, vista and 7. It worked well. So I am closing the bug.

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4677

Also available in: Atom PDF