Project

General

Profile

Bug #4734

ant run-workflow-no-gui cannot read configuration

Added by ben leinfelder almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
execution engine
Target version:
Start date:
02/04/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4734

Description

Trying to run a workflow (xml or kar) from the ant task or the kepler.sh script results in an exception reading the special noGui configuration:

[run] java.lang.Exception: Failed to parse "ptolemy/configs/kepler/ConfigNoGUIWithCache.xml -runThenExit /Users/leinfelder/workspace_kepler/kruger/workflows/tpc02-water-flow/tpc02-water-flow-base.kar"
[run] at ptolemy.actor.gui.ConfigurationApplication.throwArgsException(ConfigurationApplication.java:644)
[run] at org.kepler.KeplerConfigurationApplication.<init>(KeplerConfigurationApplication.java:289)
[run] at org.kepler.KeplerConfigurationApplication.main(KeplerConfigurationApplication.java:583)
[run] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[run] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[run] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[run] at java.lang.reflect.Method.invoke(Method.java:585)
[run] at org.kepler.Kepler.load(Kepler.java:338)
[run] at org.kepler.Kepler.load(Kepler.java:356)
[run] at org.kepler.Kepler.parseArgsAndRun(Kepler.java:284)
[run] at org.kepler.Kepler.main(Kepler.java:169)
[run] Caused by: java.lang.NullPointerException: Failed to find configuration in file:/Users/leinfelder/workspace_kepler/kepler/wrp/configs/ptolemy/configs/kepler/ConfigNoGUIWithCache.xml
[run] at ptolemy.actor.gui.ConfigurationApplication.readConfiguration(ConfigurationApplication.java:417)
[run] at org.kepler.KeplerConfigurationApplication.<init>(KeplerConfigurationApplication.java:133)

History

#1 Updated by Chad Berkley almost 10 years ago

Removed kar entry handlers from the wrp ptolemy config file. actually just removed the whole file since it was totally redundant with the common config file. all KEH's are now stored in the configuration manager.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4734

Also available in: Atom PDF