Project

General

Profile

Bug #4838

Permissions error for link contained in Data Set Citation section

Added by Jim Regetz over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Category:
registry
Target version:
Start date:
02/24/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4838

Description

It's easiest to describe this by documenting the steps to reproduce. This involves ESA, but I haven't checked whether it happens with non-public documents viewed using other registries.

After logging into ESA, click My Submissions (or View Submissions if logged in as a moderator), then click to view any one of the listed documents. Note that these are all documents that are not publicly readable, but should be readable by the logged-in user. The Data Set Citation section near the top of the document contains a link that refers to the document itself, e.g.: http://esa-dev.nceas.ucsb.edu/esa/metacat/esa.65.3/esa

Clicking on the link produces an error:

--------------------------------
This XML file does not appear to have any style information associated with it. The document tree is shown below.

<error>
User public does not have permission to read the document with the docid esa.65.3
</error>
--------------------------------

The underlying URL for the example above is:
http://esa-dev.nceas.ucsb.edu/esa/metacat?action=read&qformat=esa&sessionid=&docid=esa.65.3

Perhaps the issue is the missing session variable?


Related issues

Blocks Metacat - Bug #4834: Request to modify document redirects to registry home after loginResolved02/24/2010

History

#1 Updated by Michael Daigle over 9 years ago

fix in 1.9.2

#2 Updated by Michael Daigle over 9 years ago

Added the session Id to the read url and it works.

#3 Updated by Jim Regetz over 9 years ago

Yep, the permissions problem is fixed. However, now when clicking the link, the frame that contains the doc is replaced with a frame containing both the ESA header (which therefore appears twice on the page) and doc.

#4 Updated by Michael Daigle over 9 years ago

I changed the link results to display in the top window. This displays a straight read action for the document, which does not have the esa review pane on the side.

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4838

Also available in: Atom PDF