Project

General

Profile

Bug #4888

Runs with 1 error don't highlight red in WRM

Added by Derik Barseghian about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
workflow run manager
Target version:
Start date:
03/17/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4888

Description

Looks like the code for dealing with errors is a little broken after the recent refactor of WorkflowRun: Runs with 1 error don't highlight red in the WRM because getErrorMessages always returns 0.

History

#1 Updated by Aaron Aaron about 9 years ago

Can you describe how to reproduce the bug.

#2 Updated by Derik Barseghian about 9 years ago

Sure. Open a blank worflow and hit run. This will cause one error, yet the run row won't be highlighted red.

#3 Updated by Aaron Aaron about 9 years ago

When is setErrorMessages() called after a run? Looks like the WRM is refreshed with WorkflowRun objects constructed using provenance data?

#4 Updated by Aaron Aaron about 9 years ago

I think it's better now after revision 23398 in trunk, let me know if that works and I'll check it into the branch as well.

#5 Updated by Derik Barseghian about 9 years ago

Did a couple quick tests and it works here, thanks. Nothing to check into the branch since r23398 is just changes to wrp, provenance and wrm.

#6 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4888

Also available in: Atom PDF