Project

General

Profile

Bug #4940

User is never notified of incorrect login

Added by Chad Berkley about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
core
Target version:
Start date:
04/16/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4940

Description

When you do a data search and login, if you put an incorrect username or password, then do a search, Kepler never tells you your username/pass is incorrect and tries to do the search anyway.

To recreate:
1) go to the data tab
2) search for "aphid"
3) input a fake username/pass
4) click "ok"

Kepler will sit there like it's searching, but if you look at the log, no search is taking place and it will never tell you that the login failed. I'm unsure if the problem is with Kepler not properly handling incorrect login results from the ecogrid or if ecogrid isn't properly notifying kepler of the failed login attempt.

History

#1 Updated by Chad Berkley about 9 years ago

This actually does not fail. It just takes a ridiculous amount of time to return the <unauth_login> message from the server, during which time, it looks like Kepler is hung.

#2 Updated by Chad Berkley about 9 years ago

This appears to be a bug in ecogrid, not Kepler. Closing this in kepler, but it should be looked at in ecogrid.

#3 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4940

Also available in: Atom PDF