Project

General

Profile

Bug #4952

Error recording workflow structure on workflow after deleting run

Added by Derik Barseghian over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
provenance
Target version:
Start date:
04/19/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4952

Description

If create a workflow, run it, delete the run, then try to run the workflow again, you'll currently get an error (below). Maybe this is related to r23714 "adding method to delete provenance for workflows without runs"?

ptolemy.kernel.util.IllegalActionException: Error recording workflow structure: Error adding to workflow_change: Integrity constraint violation - no parent WORKFLOW_CHANGE_WF_ID_FK table: WORKFLOW in statement [INSERT INTO WORKFLOW_CHANGE (user, time, wf_id, host_id) VALUES (?, ?, ?, ?)]
in .Unnamed1.TOP Provenance Recorder
Because:
Error adding to workflow_change: Integrity constraint violation - no parent WORKFLOW_CHANGE_WF_ID_FK table: WORKFLOW in statement [INSERT INTO WORKFLOW_CHANGE (user, time, wf_id, host_id) VALUES (?, ?, ?, ?)]
at org.kepler.provenance.ProvenanceRecorder._recordWorkflowContents(ProvenanceRecorder.java:2266)
at org.kepler.provenance.ProvenanceRecorder.preinitialize(ProvenanceRecorder.java:473)
at ptolemy.actor.CompositeActor.preinitialize(CompositeActor.java:1424)
at ptolemy.actor.Manager.preinitializeAndResolveTypes(Manager.java:983)
at ptolemy.actor.Manager.initialize(Manager.java:643)
at ptolemy.actor.Manager.execute(Manager.java:340)
at ptolemy.actor.Manager.run(Manager.java:1162)
at ptolemy.actor.Manager$3.run(Manager.java:1215)
Caused by: org.kepler.provenance.RecordingException: Error adding to workflow_change: Integrity constraint violation - no parent WORKFLOW_CHANGE_WF_ID_FK table: WORKFLOW in statement [INSERT INTO WORKFLOW_CHANGE (user, time, wf_id, host_id) VALUES (?, ?, ?, ?)]
at org.kepler.provenance.sql.SQLRecordingV8._addWorkflowChange(SQLRecordingV8.java:1344)
at org.kepler.provenance.sql.SQLRecordingV8._addEntity(SQLRecordingV8.java:1242)
at org.kepler.provenance.sql.SQLRecording._checkEntity(SQLRecording.java:1370)
at org.kepler.provenance.sql.SQLRecording._regActorDirector(SQLRecording.java:1524)
at org.kepler.provenance.sql.SQLRecording.regActor(SQLRecording.java:140)
at org.kepler.provenance.ProvenanceRecorder._recordContainerContents(ProvenanceRecorder.java:1771)
at org.kepler.provenance.ProvenanceRecorder._recordWorkflowContents(ProvenanceRecorder.java:2252)
... 7 more
Caused by: java.sql.SQLException: Integrity constraint violation - no parent WORKFLOW_CHANGE_WF_ID_FK table: WORKFLOW in statement [INSERT INTO WORKFLOW_CHANGE (user, time, wf_id, host_id) VALUES (?, ?, ?, ?)]
at org.hsqldb.jdbc.Util.throwError(Unknown Source)
at org.hsqldb.jdbc.jdbcPreparedStatement.executeUpdate(Unknown Source)
at org.kepler.util.sql.DatabaseType.insert(DatabaseType.java:687)
at org.kepler.provenance.sql.SQLRecordingV8._addWorkflowChange(SQLRecordingV8.java:1331)
... 13 more
Caused by: org.kepler.provenance.RecordingException: Error adding to workflow_change: Integrity constraint violation - no parent WORKFLOW_CHANGE_WF_ID_FK table: WORKFLOW in statement [INSERT INTO WORKFLOW_CHANGE (user, time, wf_id, host_id) VALUES (?, ?, ?, ?)]
at org.kepler.provenance.sql.SQLRecordingV8._addWorkflowChange(SQLRecordingV8.java:1344)
at org.kepler.provenance.sql.SQLRecordingV8._addEntity(SQLRecordingV8.java:1242)
at org.kepler.provenance.sql.SQLRecording._checkEntity(SQLRecording.java:1370)
at org.kepler.provenance.sql.SQLRecording._regActorDirector(SQLRecording.java:1524)
at org.kepler.provenance.sql.SQLRecording.regActor(SQLRecording.java:140)
at org.kepler.provenance.ProvenanceRecorder._recordContainerContents(ProvenanceRecorder.java:1771)
at org.kepler.provenance.ProvenanceRecorder._recordWorkflowContents(ProvenanceRecorder.java:2252)
at org.kepler.provenance.ProvenanceRecorder.preinitialize(ProvenanceRecorder.java:473)
at ptolemy.actor.CompositeActor.preinitialize(CompositeActor.java:1424)
at ptolemy.actor.Manager.preinitializeAndResolveTypes(Manager.java:983)
at ptolemy.actor.Manager.initialize(Manager.java:643)
at ptolemy.actor.Manager.execute(Manager.java:340)
at ptolemy.actor.Manager.run(Manager.java:1162)
at ptolemy.actor.Manager$3.run(Manager.java:1215)
Caused by: java.sql.SQLException: Integrity constraint violation - no parent WORKFLOW_CHANGE_WF_ID_FK table: WORKFLOW in statement [INSERT INTO WORKFLOW_CHANGE (user, time, wf_id, host_id) VALUES (?, ?, ?, ?)]
at org.hsqldb.jdbc.Util.throwError(Unknown Source)
at org.hsqldb.jdbc.jdbcPreparedStatement.executeUpdate(Unknown Source)
at org.kepler.util.sql.DatabaseType.insert(DatabaseType.java:687)
at org.kepler.provenance.sql.SQLRecordingV8._addWorkflowChange(SQLRecordingV8.java:1331)
... 13 more

History

#1 Updated by Daniel Crawl over 9 years ago

Fixed in r23833.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4952

Also available in: Atom PDF