Project

General

Profile

Actions

Bug #4982

closed

NPE when starting with no network

Added by Daniel Crawl almost 13 years ago. Updated over 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
build system
Target version:
Start date:
05/07/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4982

Description

NPE when starting with no network:

[run] Exception in thread "main" java.lang.NullPointerException
[run] at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:105)
[run] at org.kepler.build.modules.Module.readPublished(Module.java:220)
[run] at org.kepler.modulemanager.gui.patch.PatchChecker.check(PatchChecker.java:57)
[run] at org.kepler.Kepler.main(Kepler.java:92)
[run] Caused by: java.lang.NullPointerException
[run] at org.kepler.build.PublishedTask.trimOlderNames(PublishedTask.java:49)
[run] at org.kepler.build.UpdatePublishedTxt.run(UpdatePublishedTxt.java:53)
[run] at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:101)
[run] ... 3 more
[run] --- Nested Exception ---
[run] java.lang.NullPointerException
[run] at org.kepler.build.PublishedTask.trimOlderNames(PublishedTask.java:49)
[run] at org.kepler.build.UpdatePublishedTxt.run(UpdatePublishedTxt.java:53)
[run] at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:101)
[run] at org.kepler.build.modules.Module.readPublished(Module.java:220)
[run] at org.kepler.modulemanager.gui.patch.PatchChecker.check(PatchChecker.java:57)
[run] at org.kepler.Kepler.main(Kepler.java:92)

Related issues

Blocked by Kepler - Bug #4943: RC5 Installer Tracking BugResolvedDavid Welker04/19/2010

Actions
Actions #1

Updated by David Welker over 12 years ago

Fixed.

Actions #2

Updated by Redmine Admin almost 10 years ago

Original Bugzilla ID was 4982

Actions

Also available in: Atom PDF